• HDU 5301 Buildings 数学


    Buildings

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5301

    Description

    Your current task is to make a ground plan for a residential building located in HZXJHS. So you must determine a way to split the floor building with walls to make apartments in the shape of a rectangle. Each built wall must be paralled to the building's sides.

    The floor is represented in the ground plan as a large rectangle with dimensions n×m, where each apartment is a smaller rectangle with dimensions a×b located inside. For each apartment, its dimensions can be different from each other. The number a and b must be integers.

    Additionally, the apartments must completely cover the floor without one 1×1 square located on (x,y). The apartments must not intersect, but they can touch.

    For this example, this is a sample of n=2,m=3,x=2,y=2.

    To prevent darkness indoors, the apartments must have windows. Therefore, each apartment must share its at least one side with the edge of the rectangle representing the floor so it is possible to place a window.

    Your boss XXY wants to minimize the maximum areas of all apartments, now it's your turn to tell him the answer.

    Input

    There are at most 10000 testcases.
    For each testcase, only four space-separated integers, n,m,x,y(1≤n,m≤108,n×m>1,1≤x≤n,1≤y≤m).

    Output

    For each testcase, print only one interger, representing the answer.

    Sample Input

    2 3 2 2
    3 3 1 1

    Sample Output

    1
    2

    Hint

    题意

    给你一个n*m的土地,然后让你分成若干块,你需要保证这些块至少有一条边靠近土地的边上。

    然后这个土地上有一个坏点。

    问你这些块的最小面积是多少。

    题解:

    考虑暴力,显然答案就是其中某一块砖离边界最近距离值的最大值。

    然后由于有一个坏点,那么我们就只用分析一下这个坏点附近的四个点就好了。

    然后再考虑考虑特殊情况就好了。

    代码

    #include<bits/stdc++.h>
    using namespace std;
    
    int n,m,a,b;
    int main()
    {
        while(scanf("%d%d%d%d",&n,&m,&a,&b)!=EOF)
        {
            int ans;
            int dis=0;
            if(a*2==n+1&&b*2==m+1&&n==m)
            {
                cout<<a-1<<endl;
                continue;
            }
            int x1=a,y1=b-1,x2=a,y2=b+1;
            int x3=a-1,y3=b,x4=a+1,y4=b;
            if(x1<=n&&x1>=1&&y1<=m&&y1>=1) dis=max(dis,min(x1,min(n-x1+1,y1)));
            if(x2<=n&&x2>=1&&y2<=m&&y2>=1) dis=max(dis,min(x2,min(n-x2+1,m-y2+1)));
            if(x3<=n&&x3>=1&&y3<=m&&y3>=1) dis=max(dis,min(y3,min(m-y3+1,x3)));
            if(x4<=n&&x4>=1&&y4<=m&&y4>=1) dis=max(dis,min(y4,min(m-y4+1,n-x4+1)));
            ans=max(dis,min((n+1)/2,(m+1)/2));
            if(n)
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    Xcode fold code All In One
    Xcode iOS project rename All In One
    SwiftUI App Sticker All in One
    hash算法
    TCP
    gRPC目录
    Go客户端流式gRPC
    服务端流式RPC
    protobuf简单使用
    protobuf安装
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5313345.html
Copyright © 2020-2023  润新知