• poj 3660 Cow Contest Flyod


    Cow Contest
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5989   Accepted: 3234

    Description

    N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

    The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

    Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

    Output

    * Line 1: A single integer representing the number of cows whose ranks can be determined
     

    Sample Input

    5 5
    4 3
    4 2
    3 2
    1 2
    2 5
    

    Sample Output

    2

    题意:是给你n个人,m组关系
    每次关系输入A,B。表示A比B屌
    思路:Flyod跑一发,然后判断是否这个人和其他人的关系都已经确定,如果都已经确定,那么就直接ans++就好了!

    //qscqesze
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    #include <iostream>
    #include <algorithm>
    #include <set>
    #include <vector>
    #include <sstream>
    #include <queue>
    #include <typeinfo>
    #include <fstream>
    #include <map>
    typedef long long ll;
    using namespace std;
    //freopen("D.in","r",stdin);
    //freopen("D.out","w",stdout);
    #define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
    #define maxn 105
    #define eps 1e-9
    const int inf=0x7fffffff;   //无限大
    int g[maxn][maxn];
    int main()
    {
        int n,m;
        while(cin>>n>>m)
        {
            int a,b;
            for(int i=0;i<m;i++)
            {
                cin>>a>>b;
                g[a][b]=1;
            }
            for(int k=1;k<=n;k++)
            {
                for(int i=1;i<=n;i++)
                {
                    for(int j=1;j<=n;j++)
                    {
                        if(g[i][k]&&g[k][j])
                            g[i][j]=1;
                    }
                }
            }
            int ans=0;
            for(int i=1;i<=n;i++)
            {
                int flag=1;
                for(int j=1;j<=n;j++)
                {
                    if(i==j)
                        continue;
                    if(g[i][j]==0&&g[j][i]==0)
                    {
                        flag=0;
                        break;
                    }
                }
                if(flag)
                    ans++;
            }
            cout<<ans<<endl;
        }
    }


  • 相关阅读:
    json格式
    UICollectionViewLayout继承UICollectionViewFlowLayout自定义布局
    iOS中如何生成二维码
    Xcode升级之后插件无法使用与不小心点击Skipbundle的解决办法
    如何上传本地代码到github
    Xcode实用快捷键以及Mac一些常用指令
    0925-0926 函数注意点
    0921控制结构注意点
    0920逻辑运算符,位运算,移位运算,三元运算符,短路性注意点
    0919表达式&运算符注意点
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4296122.html
Copyright © 2020-2023  润新知