• poj 1825 Ants 水题


    Ants
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 10722   Accepted: 4752

    Description

    An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

    Input

    The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

    Output

    For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

    Sample Input

    2
    10 3
    2 6 7
    214 7
    11 12 7 13 176 23 191
    

    Sample Output

    4 8
    38 207
    
    给你一堆蚂蚁,问全部蚂蚁掉下去的最少时间和最大时间
    扫一遍就好
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    #include <iostream>
    #include <algorithm>
    #include <set>
    #include <vector>
    #include <sstream>
    #include <queue>
    #include <typeinfo>
    #include <fstream>
    #include <map>
    typedef long long ll;
    using namespace std;
    //freopen("D.in","r",stdin);
    //freopen("D.out","w",stdout);
    #define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
    #define maxn 1000001
    #define eps 1e-9
    const int inf=0x7fffffff;   //无限大
    int x[maxn];
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            int l,n;
            scanf("%d%d",&l,&n);
            int min_num=inf;
            int max_num=0;
            int min_ans=0;
            int max_ans=0;
            for(int i=0;i<n;i++)
            {
                scanf("%d",&x[i]);
                min_num=min(x[i],l-x[i]);
                //cout<<min_num<<endl;
                min_ans=max(min_num,min_ans);
                max_num=max(max_num,max(x[i],l-x[i]));
            }
            cout<<min_ans<<" "<<max_num<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JavaScript学习总结(八)——JavaScript数组
    oracle数据库优化学习笔记
    把连续日期组织起来的算法
    转:andriod的盈利模式分析
    ASP.NET 页生命周期
    .NET垃圾回收机制[引用]
    IIS 7.0 的 ASP.NET 应用程序生命周期
    table滑动选择行及从表记录对应js代码
    hdu 3594 Cactus
    Java 计算器
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4290176.html
Copyright © 2020-2023  润新知