• 1029 Median (25分)


    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output Specification:

    For each test case you should output the median of the two given sequences in a line.

    Sample Input:

    4 11 12 13 14
    5 9 10 15 16 17
    
     

    Sample Output:

    13


    #include<iostream>
    using namespace std;
    
    int main()
    {
        long long n,m;
        scanf("%lld",&n);
        long long a[n];
    
        for(int i=0;i<n;i++)//输入a
        {
            scanf("%lld",&a[i]);
        }
    
        //输入b
        scanf("%lld",&m);
        long long b[m];
        for(int i=0;i<m;i++)
            scanf("%lld",&b[i]);
    
        long long i=0,j=0, mid=(n+m-1)/2;//mid 是中间位置的数
    
        while(i+j<mid)//i是a[]的下标, j是b[]的下标
        {//每一次下标移动一位,较小的那个数的下标移动,
            if(a[i]<=b[j])
                i++;
            else
                j++;
        }
    
        if(a[i]<b[j])//当跳出while循环的时候,下标较小的数就是结果
            printf("%d",a[i]);
        else
            printf("%d",b[j]);
    
        return 0;
    
    }
  • 相关阅读:
    python pickle模块
    python struct模块
    python threading模块
    python queue模块
    python3 requests模块 基本操作
    python json模块
    C语言回调函数
    工厂方法模式
    git fetch, git pull 以及 FETCH_HEAD
    git删除远程文件夹或文件的方法
  • 原文地址:https://www.cnblogs.com/qinmin/p/12902612.html
Copyright © 2020-2023  润新知