• 1067 Sort with Swap(0, i) (25分)


    Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

    Swap(0, 1) => {4, 1, 2, 0, 3}
    Swap(0, 3) => {4, 1, 2, 3, 0}
    Swap(0, 4) => {0, 1, 2, 3, 4}
    
     

    Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

    Input Specification:

    Each input file contains one test case, which gives a positive N (≤) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

    Sample Input:

    10
    3 5 7 2 6 4 9 0 8 1
    
     

    Sample Output:

    9、

    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    int main()
    {
        int n; int ans=0;//最后的答案
        scanf("%d",&n);
        int rest =n-1;//还有几个数不在本位上
    
        int pos[n];
        for(int i=0;i<n;i++)
        {
            scanf("%d",&pos[i]);//数字i存放在pos[i]
            if(pos[i]==i)
                rest--;
        }
    
        int k =1;//k存放除了0之外的不在本位上的最小数字
        while(rest)
        {
            if(pos[0]==0)//如果0在本位上
            {//则寻找一个不在本位上的数和0交换
                while(k<n)
                {
                    if(pos[k]!=k)//如果k不在本位上就和0交换
                    {
                        swap(pos[0],pos[k]);
                        ans++;
                        break;
                    }
                    k++;
                }
           }
    
             while(pos[0]!=0)
                {
                    swap(pos[0],pos[pos[0]]);
                    ans++;
                    rest--;
                }
            }
    
    
        printf("%d",ans);
    
        return 0;
    }

    这段代码只有22分,有2个点运行超时!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

     
  • 相关阅读:
    vue中计算属性computed和watch的区别
    sqlserver中pivot(行转列),unpivot(列转行)
    js本地缓存的方式Cookie、localStorage、sessionStorage
    Linux调度系统全景指南(中篇)
    Linux调度系统全景指南(终结篇)
    Linux调度系统全景指南(下篇)
    五层模型
    Linux内核概念
    网络性能
    PyMuPDF使用
  • 原文地址:https://www.cnblogs.com/qinmin/p/12694630.html
Copyright © 2020-2023  润新知