• POJ3061(尺取法)


    Subsequence
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12982   Accepted: 5491

    Description

    A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

    Input

    The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

    Output

    For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

    Sample Input

    2
    10 15
    5 1 3 5 10 7 4 9 2 8
    5 11
    1 2 3 4 5

    Sample Output

    2
    3
    思路:尺取法操作连续子段和问题。
    import java.util.Scanner;
    public class Main {
        Scanner in = new Scanner(System.in);
        final int MAXN = 100005;
        int n, s;
        int[] a = new int[MAXN];
        public Main() {
            int T = in.nextInt();
            while(T-- != 0) {
                n = in.nextInt();
                s = in.nextInt();
                for(int i = 0; i < n; i++) {
                    a[i] = in.nextInt();
                }
                int front = 0, rear = 0;
                int sum = 0;
                int res = n;
                while(true) {
                    while(rear < n && sum < s) {
                        sum += a[rear++];
                    }
                    if(sum >= s) {
                        res = Math.min(res, rear-front);
                    }
                    else {
                        break;
                    }
                    if(front < rear && sum>=s) {
                        sum -= a[front++];
                    }
                }
                if(res != n) {
                    System.out.println(res);
                }
                else {
                    System.out.println(0);
                }
            }
        }
        public static void main(String[] args) {
            
            new Main();
        }
    }
  • 相关阅读:
    CSS3 Flex布局整理(二)-容器属性
    CSS3 Flex布局整理(一)
    .Net Core中文编码问题整理
    Karma:1. 集成 Karma 和 Jasmine 进行单元测试
    Protractor
    翻译: TypeScript 1.8 Beta 发布
    webpack 插件: html-webpack-plugin
    How I came to find Linux
    翻译:Angular 2
    在 Angular 中实现搜索关键字高亮
  • 原文地址:https://www.cnblogs.com/program-ccc/p/6114464.html
Copyright © 2020-2023  润新知