• POJ3273(最大化问题)


    Monthly Expense
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 20603   Accepted: 8101

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5
    100
    400
    300
    100
    500
    101
    400

    Sample Output

    500
    题意:将N个数分成M组,使每组之和的最大值最小。

    #include <iostream>
    #include <algorithm>
    using namespace std;
    const int MAXN=100005;
    int n,m;
    int spe[MAXN];
    bool test(int mon)
    {
        int s=0;
        int sum=0;
        for(int i=0;i<n;i++)
        {
            if(spe[i]>mon)    return false;
            if(sum+spe[i]<=mon)
            {
                sum+=spe[i];
            }
            else
            {
                sum=spe[i];
                s++;
            }
        }
        s++;
        return s<=m;
    }
    int main()
    {
        while(cin>>n>>m)
        {
            for(int i=0;i<n;i++)
            {
                cin>>spe[i];
            }
            int l=0;
            int r=0x3f3f3f3f;
            while(r-l>1)
            {
                int mid=(l+r)>>1;
                if(test(mid)) r=mid;
                else l=mid;
            }
            cout<<r<<endl;
        }
        return 0;
    }
  • 相关阅读:
    好久没来博客园写博客了
    配置apache apache服务器如何配置多站点
    Discuz对不起,您安装的不是正版应用的解决办法
    解决php deprecated 的问题
    PHP乱码完美解决
    block,inline和inline-block概念和区别(转)
    C# 的各种排序
    设计模式的学习
    一些随笔
    笔记 日常的记录
  • 原文地址:https://www.cnblogs.com/program-ccc/p/5246313.html
Copyright © 2020-2023  润新知