• zzuoj--10399--Turing equation(模拟)


    Turing equation

    Time Limit: 1 Sec  Memory Limit: 128 MB
    Submit: 152  Solved: 85
    [Submit][Status][Web Board]

    Description

    The fight goes on, whether to store  numbers starting with their most significant digit or their least  significant digit. Sometimes  this  is also called  the  "Endian War". The battleground  dates far back into the early days of computer  science. Joe Stoy,  in his (by the way excellent)  book  "Denotational Semantics", tells following story:
    "The decision  which way round the digits run is,  of course, mathematically trivial. Indeed,  one early British computer  had numbers running from right to left (because the  spot on an oscilloscope tube  runs from left to right, but  in serial logic the least significant digits are dealt with first). Turing used to mystify audiences at public lectures when, quite by accident, he would slip into this mode even for decimal arithmetic, and write  things  like 73+42=16.  The next version of  the machine was  made  more conventional simply  by crossing the x-deflection wires:  this,  however, worried the engineers, whose waveforms  were all backwards. That problem was in turn solved by providing a little window so that the engineers (who tended to be behind the computer anyway) could view the oscilloscope screen from the back.

    You will play the role of the audience and judge on the truth value of Turing's equations.

    Input

    The input contains several test cases. Each specifies on a single line a Turing equation. A Turing equation has the form "a+b=c", where a, b, c are numbers made up of the digits 0,...,9. Each number will consist of at most 7 digits. This includes possible leading or trailing zeros. The equation "0+0=0" will finish the input and has to be processed, too. The equations will not contain any spaces.

    Output

    For each test case generate a line containing the word "TRUE" or the word "FALSE", if the equation is true or false, respectively, in Turing's interpretation, i.e. the numbers being read backwards.

    Sample Input

    73+42=16
    5+8=13
    0001000+000200=00030
    0+0=0

    Sample Output

    TRUE
    FALSE
    TRUE

    HINT

    Source


    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    #define mem(x,y) memset(x,y,sizeof(x))
    #define SI(x) scanf("%d",&x)
    #define SL(x) scanf("%lld",&x)
    #define  PI(x) printf("%d",x)
    #define  PL(x) printf("%lld",x)
    #define P_ printf(" ")
    const int INF=0x3f3f3f3f;
    const double PI=acos(-1.0);
    typedef long long LL;
    char s[35],t[10];
    int ans[3];
    int main()
    {
    	while(scanf("%s",s),strcmp(s,"0+0=0"))
    	{
    		int k=0,tp=0,temp=0;
    		for(int i=0;s[i];i++)
    		{
    			if(isdigit(s[i]))
    			{
    				t[k++]=s[i];
    			}
    			else
    			{
    				reverse(t,t+k);
    				for(int j=0;j<k;j++)
    				temp=temp*10+t[j]-'0';
    				ans[tp++]=temp;
    				k=0;temp=0;
    			}
    		}
    		reverse(t,t+k);
    		for(int j=0;j<k;j++)
    		temp=temp*10+t[j]-'0';
    		ans[tp++]=temp;
    		if(ans[0]+ans[1]==ans[2])
    		puts("TRUE");
    		else puts("FALSE");
    	}
    	return 0;
    }


  • 相关阅读:
    微信小程序
    如何在微信小程序中使用骨架屏
    Nlog打印日志到Influxdb数据库
    C#通过模板导出Word的两种方法(超简单)
    VS2019制作的安装包,默认安装到C盘快捷方式无法打开
    orcale数据库还原备份
    Thread 类创建线程
    Quartz.NET
    DataTable ,使用详细。
    Unity3D 学习
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273570.html
Copyright © 2020-2023  润新知