• hdoj--2122--Ice_cream’s world III(克鲁斯卡尔)


    Ice_cream’s world III

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1450    Accepted Submission(s): 496


    Problem Description
    ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
     

    Input
    Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
     

    Output
    If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
     

    Sample Input
    2 1 0 1 10 4 0
     

    Sample Output
    10 impossible
     

    Author
    Wiskey
     

    Source
     

    Recommend
    威士忌   |   We have carefully selected several similar problems for you:  2120 2121 2119 2129 2118 

    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<queue>
    #include<algorithm>
    using namespace std;
    int pre[10010];
    struct node
    {
    	int u,v,val;
    }p[10010];
    int m,n;
    void init()
    {
    	for(int i=0;i<10010;i++)
    	pre[i]=i;
    }
    int cmp(node s1,node s2)
    {
    	return s1.val<s2.val;
    }
    int find(int x)
    {
    	int r=x;
    	while(r!=pre[r])
    	r=pre[r];
    	while(x!=r)
    	{
    		int t=pre[x];
    		pre[x]=r;
    		x=t;
    	}
    	return r;
    }
    int join(int x,int y)
    {
    	int fx=find(x);
    	int fy=find(y);
    	if(fx!=fy)
    	{
    		pre[fx]=fy;
    		return 1;
    	}
    	return 0;
    }
    int main()
    {
    	while(cin>>n>>m)
    	{
    		init();
    		for(int i=0;i<m;i++)
    		cin>>p[i].u>>p[i].v>>p[i].val;
    		sort(p,p+m,cmp);
    		int sum=0;
    		for(int i=0;i<m;i++)
    		{
    			if(join(p[i].u,p[i].v))
    			sum+=p[i].val;
    		}
    		int flog=0;
    		int gen=0;
    		for(int i=0;i<n;i++)
    		{
    			if(pre[i]==i)
    			gen++;
    			if(gen>1)
    			flog=1;
    		}
    		if(flog)
    		printf("impossible
    
    ");
    		else
    		printf("%d
    
    ",sum);
    		
    	}
    	return 0;
    }


  • 相关阅读:
    Linux下状态查看相关命令
    Linux免密登录理解
    Linux下远程访问&拷贝&下载
    初识NAT、桥接和Host-Only
    Linux文件和文件夹权限管理
    Linux用户和用户组的操作
    Mac+Parallels+iTerm安装配置Linux Centos7
    SSM整合事务失效
    Linux用户和用户组管理命令
    Linux中{ }的用法
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273544.html
Copyright © 2020-2023  润新知