• poj--1236--Network of Schools(scc+缩点)


    Network of Schools
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 14062   Accepted: 5606

    Description

    A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B 
    You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school. 

    Input

    The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

    Output

    Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

    Sample Input

    5
    2 4 3 0
    4 5 0
    0
    0
    1 0
    

    Sample Output

    1
    2
    

    Source

    IOI 1996


    #include <cstdio>
    #include <cstring>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <algorithm>
    #define MAXN 100+10
    #define MAXM 10000+10
    #define INF 0x3f3f3f3f
    using namespace std;
    struct Edge
    {
        int from, to, next;
    };
    Edge edge[MAXM];
    int head[MAXN], edgenum;
    int low[MAXN], dfn[MAXN];
    int dfs_clock;
    int sccno[MAXN], scc_cnt;
    stack<int> S;
    bool Instack[MAXN];
    int N;
    void init()
    {
        edgenum = 0;
        memset(head, -1, sizeof(head));
    }
    void addEdge(int u, int v)
    {
        Edge E = {u, v, head[u]};
        edge[edgenum] = E;
        head[u] = edgenum++;
    }
    void getMap()
    {
        int y;
        for(int i = 1; i <= N; i++)
        {
            while(scanf("%d", &y), y)
                addEdge(i, y);
        }
    }
    void tarjan(int u, int fa)
    {
        int v;
        low[u] = dfn[u] = ++dfs_clock;
        S.push(u);
        Instack[u] = true;
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            v = edge[i].to;
            if(!dfn[v])
            {
                tarjan(v, u);
                low[u] = min(low[u], low[v]);
            }
            else if(Instack[v])
                low[u] = min(low[u], dfn[v]);
        }
        if(low[u] == dfn[u])
        {
            scc_cnt++;
            for(;;)
            {
                v = S.top(); S.pop();
                Instack[v] = false;
                sccno[v] = scc_cnt;
                if(v == u) break;
            }
        }
    }
    void find_cut(int l, int r)
    {
        memset(low, 0, sizeof(low));
        memset(dfn, 0, sizeof(dfn));
        memset(sccno, 0, sizeof(sccno));
        memset(Instack, false, sizeof(Instack));
        dfs_clock = scc_cnt = 0;
        for(int i = l; i <= r; i++)
            if(!dfn[i]) tarjan(i, -1);
    }
    int in[MAXN], out[MAXN];
    void suodian()
    {
        for(int i = 1; i <= scc_cnt; i++) 
    	in[i] = out[i] = 0;
        for(int i = 0; i < edgenum; i++)
        {
            int u = sccno[edge[i].from];
            int v = sccno[edge[i].to];
            if(u != v)
                in[v]++, out[u]++;
        }
    }
    void solve()
    {
        find_cut(1, N);
        suodian();
        if(scc_cnt == 1)
        {
            printf("1
    0
    ");
            return ;
        }
        int sumin = 0, sumout = 0;
        for(int i = 1; i <= scc_cnt; i++)
        {
            if(in[i] == 0)
                sumin++;
            if(out[i] == 0)
                sumout++;
        }
        printf("%d
    %d
    ", sumin, max(sumin, sumout));
    }
    int main()
    {
        while(scanf("%d", &N) != EOF)
        {
            init();
            getMap();
            solve();
        }
        return 0;
    }
    


  • 相关阅读:
    mybatis 枚举的支持
    windows系统下Disconf web安装-分布式配置管理平台
    Tomcat启动报Error listenerStart错误
    Java并发编程:volatile关键字解析
    深入理解java异常处理机制
    Java 常见异常种类
    Java RMI与RPC的区别
    Java的快速失败和安全失败
    mysql数据类型介绍(含text,longtext,mediumtext说明)
    DTO – 服务实现中的核心数据
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273528.html
Copyright © 2020-2023  润新知