• P1879 [USACO06NOV]玉米田Corn Fields


    题目描述

    Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

    Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

    农场主John新买了一块长方形的新牧场,这块牧场被划分成M行N列(1 ≤ M ≤ 12; 1 ≤ N ≤ 12),每一格都是一块正方形的土地。John打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

    遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是John不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

    John想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

    输入输出格式

    输入格式:

    第一行:两个整数M和N,用空格隔开。

    第2到第M+1行:每行包含N个用空格隔开的整数,描述了每块土地的状态。第i+1行描述了第i行的土地,所有整数均为0或1,是1的话,表示这块土地足够肥沃,0则表示这块土地不适合种草。

    输出格式:

    一个整数,即牧场分配总方案数除以100,000,000的余数。

    输入输出样例

    输入样例#1: 复制
    2 3
    1 1 1
    0 1 0
    输出样例#1: 复制
    9


    就说一句
    &两个元素一定要打括号!!!
    #include <bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define inf 2147483647
    const ll INF = 0x3f3f3f3f3f3f3f3fll;
    #define ri register int
    template <class T> inline T min(T a, T b, T c)
    {
        return min(min(a, b), c);
    }
    template <class T> inline T max(T a, T b, T c)
    {
        return max(max(a, b), c);
    }
    template <class T> inline T min(T a, T b, T c, T d)
    {
        return min(min(a, b), min(c, d));
    }
    template <class T> inline T max(T a, T b, T c, T d)
    {
        return max(max(a, b), max(c, d));
    }
    #define pi acos(-1)
    #define me(x, y) memset(x, y, sizeof(x));
    #define For(i, a, b) for (int i = a; i <= b; i++)
    #define FFor(i, a, b) for (int i = a; i >= b; i--)
    #define mp make_pair
    #define pb push_back
    const int mod=100000000;
    ;const int maxn = 1000005;
    // name*******************************
    int n,m;
    int a[15][15];
    int f[15][maxn];
    vector<int>s[10000];
    int ans=0;
    
    // function******************************
    void dfs(int i,int cur,int sum)
    {
        if(cur>m)
        {
            s[i].pb(sum);
            return;
        }
        dfs(i,cur+1,sum);
        if(a[i][cur])dfs(i,cur+2,sum+(1<<cur));
    }
    
    //***************************************
    int main()
    {
    //             freopen("test.txt", "r", stdin);
        cin>>n>>m;
        For(i,1,n)
        For(j,1,m)
        cin>>a[i][j];
        For(i,1,n)
        dfs(i,1,0);
    
    //    For(i,1,n)
    //    For(j,0,s[i].size()-1)
    //    cout<<i<<":"<<j<<":"<<s[i][j]<<endl;
    
        For(i,0,s[1].size()-1)
        f[1][i]=1;
    
        For(i,2,n)
        For(j,0,s[i].size()-1)
        For(k,0,s[i-1].size()-1)
        if((s[i][j]&s[i-1][k])==0){ 
            f[i][j]+=f[i-1][k];
        }
    
        For(i,0,s[n].size()-1)
        ans=(ans+f[n][i])%mod;
    
        cout<<ans;
    
        return 0;
    }
  • 相关阅读:
    外部编辑Infopath的表单模板(xsn)
    安装SQL Server 2008时可能遇到性能计数器不一致的情况
    Windows应用程序中使用Windows验证方式要注意的地方
    在MOSS 2007中使用Web Capture这个WebPart
    MOSS 配置SSO的时候可能遇到"您没有执行此操作的权限"的错误
    基于Web的操作系统,是否有可能?
    ASP.NET 中对于异常的处理
    在读取站点地图时自动应用安全设置
    JavaScript中的Window窗口对象【转载】
    当动态TSQL语句遇到除零的问题
  • 原文地址:https://www.cnblogs.com/planche/p/8665743.html
Copyright © 2020-2023  润新知