• P2904 [USACO08MAR]跨河River Crossing


    题目描述

    Farmer John is herding his N cows (1 <= N <= 2,500) across the expanses of his farm when he finds himself blocked by a river. A single raft is available for transportation.

    FJ knows that he must ride on the raft for all crossings and that that adding cows to the raft makes it traverse the river more slowly.

    When FJ is on the raft alone, it can cross the river in M minutes (1 <= M <= 1000). When the i cows are added, it takes M_i minutes (1 <= M_i <= 1000) longer to cross the river than with i-1 cows (i.e., total M+M_1 minutes with one cow, M+M_1+M_2 with two, etc.). Determine the minimum time it takes for Farmer John to get all of the cows across the river (including time returning to get more cows).

    Farmer John以及他的N(1 <= N <= 2,500)头奶牛打算过一条河,但他们所有的渡河工具,仅仅是一个木筏。 由于奶牛不会划船,在整个渡河过程中,FJ必须始终在木筏上。在这个基础上,木筏上的奶牛数目每增加1,FJ把木筏划到对岸就得花更多的时间。 当FJ一个人坐在木筏上,他把木筏划到对岸需要M(1 <= M <= 1000)分钟。当木筏搭载的奶牛数目从i-1增加到i时,FJ得多花M_i(1 <= M_i <= 1000)分钟才能把木筏划过河(也就是说,船上有1头奶牛时,FJ得花M+M_1分钟渡河;船上有2头奶牛时,时间就变成M+M_1+M_2分钟。后面的依此类推)。那么,FJ最少要花多少时间,才能把所有奶牛带到对岸呢?当然,这个时间得包括FJ一个人把木筏从对岸划回来接下一批的奶牛的时间。

    输入输出格式

    输入格式:

    * Line 1: Two space-separated integers: N and M

    * Lines 2..N+1: Line i+1 contains a single integer: M_i

    输出格式:

    * Line 1: The minimum time it takes for Farmer John to get all of the cows across the river.

    输入输出样例

    输入样例#1: 复制
    5 10 
    3 
    4 
    6 
    100 
    1 
    
    输出样例#1: 复制
    50 
    

    说明

    There are five cows. Farmer John takes 10 minutes to cross the river alone, 13 with one cow, 17 with two cows, 23 with three, 123 with four, and 124 with all five.

    Farmer John can first cross with three cows (23 minutes), then return (10 minutes), and then cross with the last two (17 minutes). 23+10+17 = 50 minutes total.

    #include<bits/stdc++.h>
    using namespace std;
    #define For(i,a,b) for(int i=a;i<=b;i++)
    #define FFor(i,a,b) for(int i=a;i>=b;i--)
    #define ll long long
    #define mem(a,b) memset(a,b,sizeof(a))
    #define mod 100000000
    #define maxn 2505
    #define inf 0x3f3f3f3f
    
    int n,m;
    int f[maxn];
    int w[maxn];
    int x;
    int sum[maxn];
    
    int main()
    {
        mem(f,127);
        cin>>n>>m;
        For(i,1,n)
        {
            cin>>x;
            sum[i]+=sum[i-1]+x;
            w[i]+=2*m+sum[i];
        }
    
        f[0]=0;
        For(i,1,n)
        {
            For(j,1,i)
            {
                f[i]=min(f[i],f[i-j]+w[j]);
            }
    //        cout<<i<<":"<<f[i]<<endl;
        }
        f[n]-=m;
        cout<<f[n];
    
        return 0;
    }
  • 相关阅读:
    Android json操作之取得一个对象
    Uubntu E: Sub-process /usr/bin/dpkg returned an error code问题的解决办法
    转 Android
    Android 将从网络获取的数据缓存到私有文件
    Android 每隔3s更新一次title
    Android UI主线程与子线程
    Android 解析JSON数组
    MySql中的内外联结查询
    MySQL执行外部sql脚本
    Ubuntu 下启动/停止/重启mysql服务
  • 原文地址:https://www.cnblogs.com/planche/p/8650467.html
Copyright © 2020-2023  润新知