• poj3273最大化最小值


    Monthly Expense
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 32527   Accepted: 12227

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5
    100
    400
    300
    100
    500
    101
    400

    Sample Output

    500

    Hint

    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    
    using namespace std;
    
    int a[100010];
    int N,M;
    
    bool f(int mid)         //最小值为mid的时的个数
    {
    	int sum=0;
    	int len=1;
    	for(int i=1;i<=N;i++)
    	{
    		if(sum+a[i]<=mid)
    		{
    			sum+=a[i];
    		}
    		else
    		{
    			sum=a[i];
    			len++;
    		}
    	}
    	if(len>M) return false;
    	else return true; 
    }
    
    int main(int argc, char const *argv[])
    {
    	while(cin>>N>>M)
    	{
    		double high=0,low=0;
    		for(int i=1;i<=N;i++)
    		{
    			cin>>a[i];
    			high+=a[i];
    			if(low<a[i])
    			{
    				low=a[i];
    			}
    		}
    		int mid=(low+high)/2;
    		while(low<high)
    		{
    			
    			if(!f(mid))
    			{
    				low=mid+1;
    			}
    			else
    			{
    				high=mid-1;
    			}
    			mid=(low+high)/2;
    		}
    		cout<<mid<<endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    网络存储系统NSS基准性能测试(7.10)
    Design and Model Analysis of the ECommerce Development Platform for 3Tiered Web Applications
    网络存储系统NSS基准性能测试(7.24)
    Android雁翎刀之ImageView之哈哈镜
    Android雁翎刀之ImageView之舞动乾坤
    Android雁翎刀之ImageView之异步下载
    网络存储系统NSS基准性能测试(7.17)
    freeradius源码安装及相关问题解释
    解决linux乱码显示的问题
    在ubtunu使用aptget安装和配置freeradius
  • 原文地址:https://www.cnblogs.com/passion-sky/p/9003737.html
Copyright © 2020-2023  润新知