• 杭电OJ_DIY_YTW2_1001 A Mathematical Curiosity


    Problem Description

    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.

    Input

    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

    Output

    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

    Sample Input

    1
    
    10 1
    20 3
    30 4
    0 0
    

    Sample Output

    Case 1: 2
    Case 2: 4
    Case 3: 5
    

    Source

    East Central North America 1999, Practice

    题目分析:题意是说,第一行输入一个数N,分N模块进行输入输出,在模块中输入一组(n,m),使它们同时满足0 < a < b < n和 (a^2+b^2 +m)/(ab)是整数的解的个数。
    注意:模块之间的输入输出要有一个空行,还有输入时逻辑运算的应用。


    #include<iostream>
    using namespace std;
    int main()
    {
    	int a,b,m,n,num,i,s,N;
    	cin>>N;
    	for(i=0;i<N;i++)
    	{
    		s=1;
    		while(cin>>n>>m,n||m)
    		{
    			num=0;
    			for(a=1;a<n;a++)
    			{
    				for(b=a+1;b<n;b++)
    				{
    					if((a*a+b*b+m)%(a*b)==0)
    						num++;
    				}
    			}
    			cout<<"Case "<<s<<": "<<num<<endl;
    			s++;
    		}
    		if(i!=N-1)
    			cout<<endl;			//至关重要,各模块间有一行是空行。
    	}
    	return 0;
    }
    


    程序运行如下:


  • 相关阅读:
    JavaScript Eval 函数使用
    WPFToolkit Calendar & DatePicker 使用介绍
    Windows Mobile 6.5 配置环境,数据库访问,部署简单实例
    ThreadPool.QueueUserWorkItem 方法 (WaitCallback)
    Windws Mobile 6.5 Professional ADO.NET数据访问
    WPF调用Web Services
    c#中Interface的理解
    PagesSection.MaintainScrollPositionOnPostBack 属性
    EclipseRCP中文语言包版本不一致,导致导出错误
    SWT美化开源控件网站
  • 原文地址:https://www.cnblogs.com/pangblog/p/3313286.html
Copyright © 2020-2023  润新知