• POJ 2112 Optimal Milking (二分+最短路径+网络流)


    POJ  2112 Optimal Milking (二分+最短路径+网络流)


    Optimal Milking
    Time Limit: 2000MS   Memory Limit: 30000K
    Total Submissions: 10176   Accepted: 3698
    Case Time Limit: 1000MS

    Description

    FJ has moved his K (1 <= K <= 30) milking machines out into the cow pastures among the C (1 <= C <= 200) cows. A set of paths of various lengths runs among the cows and the milking machines. The milking machine locations are named by ID numbers 1..K; the cow locations are named by ID numbers K+1..K+C. 

    Each milking point can "process" at most M (1 <= M <= 15) cows each day. 

    Write a program to find an assignment for each cow to some milking machine so that the distance the furthest-walking cow travels is minimized (and, of course, the milking machines are not overutilized). At least one legal assignment is possible for all input data sets. Cows can traverse several paths on the way to their milking machine. 

    Input

    * Line 1: A single line with three space-separated integers: K, C, and M. 

    * Lines 2.. ...: Each of these K+C lines of K+C space-separated integers describes the distances between pairs of various entities. The input forms a symmetric matrix. Line 2 tells the distances from milking machine 1 to each of the other entities; line 3 tells the distances from machine 2 to each of the other entities, and so on. Distances of entities directly connected by a path are positive integers no larger than 200. Entities not directly connected by a path have a distance of 0. The distance from an entity to itself (i.e., all numbers on the diagonal) is also given as 0. To keep the input lines of reasonable length, when K+C > 15, a row is broken into successive lines of 15 numbers and a potentially shorter line to finish up a row. Each new row begins on its own line. 

    Output

    A single line with a single integer that is the minimum possible total distance for the furthest walking cow. 

    Sample Input

    2 3 2
    0 3 2 1 1
    3 0 3 2 0
    2 3 0 1 0
    1 2 1 0 2
    1 0 0 2 0
    

    Sample Output

    2
    

    Source




    题目大意:这题的主要意思就是,K台机器,C头牛,每台机器可供M个牛,然后K+C行以及列 告诉它们间的路径,问所有牛中,走得最远的那头牛,走了多远?

    解题思路:二分最远距离,floyd最短路径算出牛到每台机器的距离,根据二分的距离来构造图的连通性,构造网络图后用网络流计算最大流量是否为牛的总数,一步步二分得到结果。


    #include <iostream>
    #include <cstdio>
    #include <queue>
    #include <cstdlib>
    using namespace std;
    
    const int maxn=300;
    const int inf=1<<28;
    struct edge{
    	int u,v,next,f;
    	edge(int u0=0,int v0=0,int f0=0,int next0=0){
    		u=u0,v=v0,f=f0,next=next0;
    	}	
    }e[maxn*maxn];
    int head[maxn*2],visited[maxn*2],path[maxn*2],a[maxn][maxn];
    int cnt,from,to,marked,K,C,M;
    
    void ini(){
    	from=0;to=K+C+1;
    }
    
    void initial(){
    	cnt=0;marked=1;
    	for(int i=0;i<=to;i++){
    		head[i]=-1;
    		visited[i]=0;
    	}
    }
    
    void adde(int u,int v,int f){
    	e[cnt].u=u,e[cnt].v=v,e[cnt].f=f,e[cnt].next=head[u],head[u]=cnt++;
    	e[cnt].u=v,e[cnt].v=u,e[cnt].f=0,e[cnt].next=head[v],head[v]=cnt++;
    }
    
    void input(){
    	int c0,n=K+C;
    	for(int i=1;i<=n;i++)
    	for(int j=1;j<=n;j++){
    		scanf("%d",&c0);
    		if(c0>0) a[i][j]=c0;
    		else a[i][j]=inf;
    	}
    	for(int k=1;k<=n;k++)
    	for(int i=1;i<=n;i++)
    	for(int j=1;j<=n;j++){
    		if(a[i][k]+a[k][j]<a[i][j]) a[i][j]=a[i][k]+a[k][j];
    	}
    }
    
    void build(int x){
    	initial();
    	for(int i=1;i<=K;i++) adde(from,i,M); //机器 1 - K 编号 
    	for(int i=K+1;i<=K+C;i++) adde(i,to,1); //牛 K+1 - K+C 编号
    	for(int i=1;i<=K;i++){
    		for(int j=K+1;j<=K+C;j++){
    			if(a[i][j]<=x) adde(i,j,1);
    		}
    	}
    } 
    
    bool bfs(){
         int s=from,d;
         queue <int> q;
         q.push(s);
         marked++;
         visited[s]=marked;
         while(!q.empty()){
             s=q.front();
             q.pop();
             for(int i=head[s];i!=-1;i=e[i].next){
                  d=e[i].v;
                  if(visited[d]!=marked && e[i].f>0){
                       visited[d]=marked;
                       path[d]=i;
                       q.push(d);
                       if(d==to) return true;
                  }
             }
         }
         return false;
    }
    
    int maxf(int x){
         build(x);	  
    	 int maxflow=0; 
         while(bfs() ){
         	int offflow=inf;   	
         	for(int i=to;i!=from;i=e[path[i]].u){
         		offflow=min(e[path[i]].f,offflow);
            }
            for(int i=to;i!=from;i=e[path[i]].u){
         		e[path[i]].f-=offflow;
             	e[path[i]^1].f+=offflow;
            }
            maxflow+=offflow;
         }
         return maxflow;
    }
    
    void computing(){
    	int l=1,r=200000;
    	while(l<r){
    		int mid=(l+r)/2;
    		if(maxf(mid)>=C) r=mid;
    		else l=mid+1;
    	}
    	cout<<r<<endl;
    }
    
    int main(){
    	while(cin>>K>>C>>M){
    		ini();
    		input();
    		computing();
    	}
    	return 0;
    }




  • 相关阅读:
    海量图片曝光百度新家“搜索框”大厦
    您玩儿转手机通讯录了吗?
    这是给开发者的弥天大谎还是至理名言?
    互联网创业,不要让经验挡住你前进的道路
    永远不要去请示是否应该整理一下你的代码
    LinkedIn开放软件平台 开发者可集成其技术
    马云建新"淘宝" 借传统媒体补课线下消费群
    乔布斯的五大魔法
    全能 Google 服务提醒软件,GoogSysTray
    Twitter用户偏好新闻 Facebook用户更喜欢科技
  • 原文地址:https://www.cnblogs.com/pangblog/p/3285599.html
Copyright © 2020-2023  润新知