• HDU 2069 Coin Change


    Coin Change

    Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 10924 Accepted Submission(s): 3669


    Problem Description
    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
     
    Input
    The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
     
    Output
    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
     
    Sample Input
    11 26
     
    Sample Output
    4 13
     

    母函数

    import java.io.*;
    import java.util.*;
    public class Main {
    	public int money[]={1,5,10,25,50};
    	public int M=250;
    	public int patten[][]=new int[M+1][M+1];
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	public void work(){
    		init();
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNextInt()){
    			int n=sc.nextInt();
    			if(n==0){
    				System.out.println(1);
    			}
    			else{
    				int sum=0;
    				for(int i=1;i<=n&&i<=100;i++){
    					sum+=patten[i][n];
    				}
    				System.out.println(sum);
    			}
    		}
    	}
    	public void init(){
    		patten[0][0]=1;
    		for(int i=0;i<5;i++){
    			for(int j=1;j<=100;j++){
    				for(int k=money[i];k<=M;k++){
    					patten[j][k]=patten[j][k]+patten[j-1][k-money[i]];
    				}
    			}
    		}
    	}
    }
    


     

  • 相关阅读:
    跟踪spring MVC的请求
    spring的Java注解方式
    spring IOC理解
    spring aop
    spring mvc开发过程中的乱码问题
    springmvc的Controller里实现转发的同时弹出提示对话框
    C++程序加速的12个方法
    VSCode官方配置C/C++
    VSCode配置C/C++环境
    Numba 0.44 中文文档
  • 原文地址:https://www.cnblogs.com/pangblog/p/3258026.html
Copyright © 2020-2023  润新知