• HDU 1164 Eddy's research I(素数打表)


    Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

    Input
    The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
    Output
    You have to print a line in the output for each entry with the answer to the previous question.
    Sample Input
    11
    9412
    Sample Output
    11
    2213*181

    题意:

    任何一个数都能拆分成质因子相乘。

    题解:

    把范围内的所有素数筛选出来,然后找就行了。

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    const int maxn=1e5+5;
    int prime[maxn];
    int is_prime[maxn];
    int sieve(int n)
    {
        int cnt=0;
        for(int i=0;i<=n;i++)
            is_prime[i]=true;
        is_prime[0]=is_prime[1]=false;
        for(int i=2;i<=n;i++)
        {
            if(is_prime[i])
            {
                prime[cnt++]=i;
                for(int j=2*i;j<=n;j+=i)
                    is_prime[j]=false;
            }
        }
        return cnt;
    }
    int main()
    {
        int k=sieve(65535);
        int n;
        while(cin>>n)
        {
            bool flag=true;
            for(int i=0;i<k;i++)
            {
                while(n&&n%prime[i]==0)
                {
                    n/=prime[i];
                    if(flag)
                    {
                        flag=false;
                        cout<<prime[i];
                    }
                    else
                        cout<<'*'<<prime[i];
                }
                if(!n)
                    break;
            }
            cout<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    字符串匹配的KMP算法(转)
    二分查找谜题
    快排的优化--说说尾递归
    ZR提高失恋测4
    CF1209
    ZR普转提2
    ZR提高失恋测3
    ZR提高失恋测2(9.7)
    ZR9.8普转提
    CF1214
  • 原文地址:https://www.cnblogs.com/orion7/p/7930979.html
Copyright © 2020-2023  润新知