• HDU 6627 2017ACM/ICPC亚洲区域赛沈阳站 Rabbits


    Problem Description
    Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
    Help them play as long as possible

    Input
    The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
    For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1 < a2 < a3 < ... < aN which are the initial positions of the rabbits. For each rabbit, its initial position
    ai satisfies 1 ≤ ai ≤ 10000.

    Output
    For each case, output the largest number of moves the rabbits can make.

    Sample Input
    5
    3
    3 4 6
    3
    2 3 5
    3
    3 5 9
    4
    1 2 3 4
    4
    1 2 4 5

    Sample Output
    1
    1
    3
    0
    1

    题意:

    有N个兔子在数轴上,最外面的兔子可以移动到其他任意两个兔子之间的位置上,一个位置只能待一次。问最大移动的次数。

    题解:

    其实想想很简单,答案就是相邻兔子的距离和 减去 第一段距离和最后一段距离中的较小值。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxn=505;
    int a[maxn];
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            int n;
            cin>>n;
            for(int i=0;i<n;i++)
                cin>>a[i];
            int sum=0;
            for(int i=1;i<n;i++)
            {
                int x=a[i]-a[i-1]-1;
                sum+=x;
            }
            int x=a[1]-a[0]<a[n-1]-a[n-2]?a[1]-a[0]:a[n-1]-a[n-2];
            cout<<sum-x+1<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    二分搜索
    中文分词 (机械传统方法 )正向最大匹配
    推荐引擎概述(转自IBM worker)
    linux OS 多线程学习
    FastReport.Net传递报表参数
    MSSQL 2008 镜像的客户端数据库连接字符串
    FastReport.Net自动行高
    ReSharper 8.0开发版 ReSharper 8.0 Early Access
    客户端FastReport.Net默认界面语言
    ReSharper 7.0 正式版发布
  • 原文地址:https://www.cnblogs.com/orion7/p/7783554.html
Copyright © 2020-2023  润新知