• HDU 2066 一个人的旅行(Dijkstra求最短路)


    虽然草儿是个路痴(就是在杭电待了一年多,居然还会在校园里迷路的人,汗~),但是草儿仍然很喜欢旅行,因为在旅途中 会遇见很多人(白马王子,0),很多事,还能丰富自己的阅历,还可以看美丽的风景……草儿想去很多地方,她想要去东京铁塔看夜景,去威尼斯看电影,去阳明山上看海芋,去纽约纯粹看雪景,去巴黎喝咖啡写信,去北京探望孟姜女……眼看寒假就快到了,这么一大段时间,可不能浪费啊,一定要给自己好好的放个假,可是也不能荒废了训练啊,所以草儿决定在要在最短的时间去一个自己想去的地方!因为草儿的家在一个小镇上,没有火车经过,所以她只能去邻近的城市坐火车(好可怜啊~)。
    Input
    输入数据有多组,每组的第一行是三个整数T,S和D,表示有T条路,和草儿家相邻的城市的有S个,草儿想去的地方有D个;
    接着有T行,每行有三个整数a,b,time,表示a,b城市之间的车程是time小时;(1=<(a,b)<=1000;a,b 之间可能有多条路)
    接着的第T+1行有S个数,表示和草儿家相连的城市;
    接着的第T+2行有D个数,表示草儿想去地方。
    Output
    输出草儿能去某个喜欢的城市的最短时间。
    Sample Input
    6 2 3
    1 3 5
    1 4 7
    2 8 12
    3 8 4
    4 9 12
    9 10 2
    1 2
    8 9 10
    Sample Output
    9

    题意:

    题解:

    求最短路径。入门题,直接跑一遍dijkstra就行了。

    #include<iostream>
    #include<queue>
    #include<algorithm>
    using namespace std;
    const int maxn=1005,INF=0x3f3f3f3f;
    int cost[maxn][maxn];//边的权值
    int d[maxn];
    bool used[maxn];
    int n=maxn;
    void dijkstra(int s)//从起点s出发到各个顶点的最短距离	
    {
    	fill(used,used+n,false);
    	fill(d,d+n,INF);
    	d[s]=0;
    	while(true)
    	{
    		int v=-1;
    		for(int u=0;u<n;u++)//从尚未使用过的顶点里选择一个距离最小的顶点
    			if(!used[u]&&(v==-1||d[u]<d[v]))
    				v=u;
    		if(v==-1)
    			break;
    		used[v]=true;
    		for(int u=0;u<n;u++)
    			d[u]=min(d[u],d[v]+cost[v][u]);
    	}
    }
    int main()
    {
    	ios::sync_with_stdio(false);
    	int t,s,q;
    	while(cin>>t>>s>>q)
    	{
    		for(int i=0;i<n;i++)
    			for(int j=i+1;j<n;j++)
    				cost[i][j]=cost[j][i]=INF;
    		while(t--)
    		{
    			int u,v,c;
    			cin>>u>>v>>c;
    			if(c<cost[u][v])
    				cost[u][v]=cost[v][u]=c;
    		}
    		while(s--)
    		{
    			int x;
    			cin>>x;
    			cost[0][x]=cost[x][0]=0;
    		}
    		dijkstra(0);
    		int ans=INF;
    		while(q--)
    		{
    			int x;
    			cin>>x;
    			ans=min(ans,d[x]);
    		}
    		cout<<ans<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    hadoop 2.6.0 LightWeightGSet源码分析
    推断扫描后的内容是否是URL
    Merge Sorted Array
    带条件的分页【重点】
    第8章2节《MonkeyRunner源代码剖析》MonkeyRunner启动执行过程-解析处理命令行參数
    php持续集成环境笔记
    hdu5137 How Many Maos Does the Guanxi Worth(单源最短路径)
    求最长公共子序列
    集团公司(嵌入ETL工具)財务报表系统解决方式
    ADT+NDK搭建jni编译环境
  • 原文地址:https://www.cnblogs.com/orion7/p/7718929.html
Copyright © 2020-2023  润新知