• POJ2524并查集水题


    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7

    题意:学校有n个同学,每个同学有且只有一个信仰,给出m对有同一信仰的同学,问存在多少种不同的信仰?
    输入0 0时结束程序。

    思路:初始有n位同学,有n个集合,有n个信仰,对于给出的m对同学:若原来不知他们有同一信仰,则合并他们各自所在集合`信仰数减一。

    #include <cstdio>

    using namespace std;

    #define max_n 50050

    int n,m;
    int par[max_n];

    void init(int n)
    {
        for(int i=1;i<=n;i++)
        {
            par[i]=i;
        }
    }

    int find(int x)
    {
        if(par[x]==x)
            return x;
        else
        {
            return par[x]=find(par[x]);
        }
    }

    bool same(int x,int y)
    {
        return find(x)==find(y);
    }

    void unit(int x,int y)
    {
        int fx=find(x);
        int fy=find(y);
        par[fx]=fy;
    }

    int main()
    {
        int d=1;
        while(scanf("%d%d",&n,&m))
        {
            if(n==0&&m==0)
                break;
            init(n);
            int ans=n;
            for(int i=1;i<=m;i++)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                if(!same(x,y))
                {
                    ans--;
                    unit(x,y);
                }
            }
            printf("Case %d: %d ",d,ans);
            d++;
        }
        return 0;
    }


  • 相关阅读:
    (转)[Android实例] 关于使用ContentObserver监听不到删除短信会话的解决方案
    (转)Android 使用com.j256.ormlite
    Android中判断网络连接是否可用及监控网络状态
    2018/11/12-操作系统课笔记
    mysql的ONLY_FULL_GROUP_BY语义 --转自http://www.wtoutiao.com/p/19dh3ec.html
    nginx相关配置说明
    为重负网络优化 Nginx 和 Node.js --引用自https://linux.cn/article-1314-1.html
    windows环境下局域网内无法访问apache站点
    27个知名企业品牌VI视觉识别系统规范手册
    TopShelf&Quartz.Net实现多任务的值守
  • 原文地址:https://www.cnblogs.com/onlyli/p/6761275.html
Copyright © 2020-2023  润新知