• dp(最大分段和)


    http://acm.hdu.edu.cn/showproblem.php?pid=1024

    Max Sum Plus Plus

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 45548    Accepted Submission(s): 16529


    Problem Description
    Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

    Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

    Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

    But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
     
    Input
    Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
    Process to the end of file.
     
    Output
    Output the maximal summation described above in one line.
     
    Sample Input
    1 3 1 2 3 2 6 -1 4 -2 3 -2 3
     
    Sample Output
    6 8
    Hint
    Huge input, scanf and dynamic programming is recommended.
     
    Author
    JGShining(极光炫影)
     
    //#include <bits/stdc++.h>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <algorithm>
    #include <iostream>
    #include <string>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <map>
    #include <set>
    #include <string.h>
    #include <vector>
    #define ME(x , y) memset(x , y , sizeof(x))
    #define SF(n) scanf("%d" , &n)
    #define rep(i , n) for(int i = 0 ; i < n ; i ++)
    #define INF  0x3f3f3f3f
    #define mod 1000000007
    #define PI acos(-1)
    using namespace std;
    typedef long long ll ;
    int a[1000009];
    int dp[1000009];
    int Max[1000009];
    
    int main()
    {
        int n ,  m;
        while(~scanf("%d%d" , &n , &m))
        {
            for(int i = 1 ; i <= m ; i++)
            {
                scanf("%d" , &a[i]);
            }
            memset(dp , 0 , sizeof(dp));
            memset(Max , 0 , sizeof(Max));
            int mmax ;
            for(int i = 1 ; i <= n ; i++)
            {
                mmax = -INF ;
                for(int j = i ; j <= m ; j++)
                {
                    dp[j] = max(dp[j - 1] , Max[j - 1]) + a[j];
                    Max[j-1] = mmax ;
                    mmax = max(mmax , dp[j]);
                }
            }
            cout << mmax << endl;
    
        }
    
        return 0;
    }
  • 相关阅读:
    PyScript 使用(1)
    振兴二线城市,输送一线it人员
    devops部署过慢
    Masked Language Modeling Maybe Helpful for Prompt learning Testing ?
    E 2022.4.4 2
    Kaggle踩坑记
    Go从入门到精通——示例:并发打印
    Go从入门到精通——示例:Telnet 回音服务器——TCP服务器的基本结构
    Go从入门到精通—示例:模拟远程过程调用(RPC)
    Kubernetes——centos8.0 使用kubeadm部署 k8sv1.18.20+etcdv3.3.10+flannelv0.10.0 高可用集群
  • 原文地址:https://www.cnblogs.com/nonames/p/11709850.html
Copyright © 2020-2023  润新知