• 01背包(排序)


    http://acm.hdu.edu.cn/showproblem.php?pid=3466

    Proud Merchants

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
    Total Submission(s): 9596    Accepted Submission(s): 4032


    Problem Description
    Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
    The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
    If he had M units of money, what’s the maximum value iSea could get?

     
    Input
    There are several test cases in the input.

    Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
    Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

    The input terminates by end of file marker.

     
    Output
    For each test case, output one integer, indicating maximum value iSea could get.

     
    Sample Input
    2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
     
    Sample Output
    5 11
     
    Author
    iSea @ WHU
     
    Source
    https://www.cnblogs.com/nwpuacmteams/articles/5777815.html
     
    //#include <bits/stdc++.h>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <algorithm>
    #include <iostream>
    #include <algorithm>
    #include <iostream>
    #include <cstdio>
    #include <string>
    #include <cstring>
    #include <stdio.h>
    #include <queue>
    #include <stack>;
    #include <map>
    #include <set>
    #include <string.h>
    #include <vector>
    #define ME(x , y) memset(x , y , sizeof(x))
    #define SF(n) scanf("%d" , &n)
    #define rep(i , n) for(int i = 0 ; i < n ; i ++)
    #define INF  0x3f3f3f3f
    #define mod 1000000007
    #define PI acos(-1)
    using namespace std;
    typedef long long ll ;
    int dp[5009] , s[5009];
    
    struct node
    {
        int p , w , val;
    }node[509];
    
    bool cmp(struct node a , struct node b)
    {
        return a.w - a.p < b.w - b.p ;
    }
    
    int main()
    {
        int n , v ;
        while(~scanf("%d%d" , &n , &v))
        {
            for(int i = 1 ; i <= n ; i++)
            {
                scanf("%d%d%d" , &node[i].p , &node[i].w , &node[i].val);
            }
            sort(node+1 , node+1+n , cmp);
            memset(dp , 0 , sizeof(dp));
    
            for(int i = 1 ; i <= n ; i++)
            {
                for(int j = v ; j >= node[i].w ; j--)
                {
                    dp[j] = max(dp[j] , dp[j-node[i].p] + node[i].val);
                }
            }
            cout << dp[v] << endl ;
        }
    
        return 0;
    }
  • 相关阅读:
    Kibana查询说明
    windows下安装python 且 安装pip
    pycharm编辑器,各种设置及配置修改
    用python输出未来时间,递增
    window 下python2.7与python3.5两版本共存设置
    python 运算符
    python 运算及注释
    js 实现动态的图片时钟
    js table的笔记,实现添加 td,实现搜索功能
    js实现图片无缝连接
  • 原文地址:https://www.cnblogs.com/nonames/p/11703015.html
Copyright © 2020-2023  润新知