• HDU 3038 How Many Answers Are Wrong


    Problem Description
    TT and FF are ... friends. Uh... very very good friends -________-b

    FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

    Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

    Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

    The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

    However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

    What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

    But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
     
    Input
    Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

    Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

    You can assume that any sum of subsequence is fit in 32-bit integer.
     
    Output
    A single line with a integer denotes how many answers are wrong.
     
    Sample Input
    10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
     
    Sample Output
    1
     
     
     
     
    简单的并查集,相对于POJ 1733 Parity game来说,简单好多了。
     
    #include <iostream> 
    //#include<fstream>
    using namespace std;
    //ifstream cin("cin.in");
    //ofstream cout("cout.out");
    
    int n,m,ans=0;
    int f[200001],d[200001]; 
    
    int Find(int x){
        if(x==f[x]) return x;
        int fx=f[x];
        f[x]=Find(fx);
        d[x]+=d[fx]; 
        return f[x]; 
        } 
    
    int main()
    {
        while(cin>>n>>m)
        {
         ans=0; 
         for(int i=1;i<=n;++i)
         f[i]=i;
         memset(d,0,sizeof(d)); 
        
         for(int i=1;i<=m;++i)
         {
          int x,y,z;
          cin>>x>>y>>z;
         
          x--; 
          int fx=Find(x),fy=Find(y);
         
          if(fx==fy)
          {
           if(d[x]+z==d[y]) continue;
           else ans++;     
                    } 
          else 
          {
           if(fx>fy) {f[fx]=fy;d[fx]=d[y]-d[x]-z;}
           else {f[fy]=fx;d[fy]=d[x]+z-d[y];}
               } 
                
                } 
        
        cout<<ans<<endl;//system("pause"); 
             } 
        
        return 0; 
        
        } 
    

      

  • 相关阅读:
    Queueing at Bank【PAT 1017题】
    table标签的布局
    股票投资的24堂必修课1
    股票投资的24堂必修课2基本面分析
    Eclipse最全快捷键 分享便捷与快乐
    浅析将matlab函数编译成dll供Cpp调用的方法
    Python编程语言中调用Matlab绘制保存数据的方案
    Eclipse中10个最有用的快捷键组合
    WPF 4 DataGrid 控件(进阶篇二)
    VBS 操作 IIS
  • 原文地址:https://www.cnblogs.com/noip/p/2552371.html
Copyright © 2020-2023  润新知