• poj 1027 The 3n + 1 problem(模拟,水题)


    The 3n + 1 problem
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 43840   Accepted: 13797

    Description

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
    Consider the following algorithm:


    1. input n

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then n <-- 3n+1

    5. else n <-- n/2

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

    Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    Output

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10
    100 200
    201 210
    900 1000

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174

    Source

    注意:

    (1)i和j的大小需要判断,但是输出时要和输入时一致。

    (2)这里用的是暴力,一开始只是尝试的态度,本以为会超时的,没想到过了。

    #include <stdio.h>
    #define GET_MAX(a,b) a>b?a:b
    #define GET_MIN(a,b) a<b?a:b
    
    int get_cycle_length(int num)
    {
        int count = 1;
        while(num!=1)
        {
            if(num%2==0)
            num /= 2;
            else num = 3*num+1;
            count++;
        }
        return count;
    }
    
    int main()
    {
        int begin,end;
        int i,j,k,length,max,index;
        while(scanf("%d%d",&i,&j)!=EOF)
        {
            max = -1;
            begin = GET_MIN(i,j);
            end = GET_MAX(i,j);
            for(k = begin; k<= end;k++)
            {
                length = get_cycle_length(k);
                if(length>max)
                {
                    max = length;
                    index = k;
                }
            }
            printf("%d %d %d\n",i,j,max);
        }
        return 0;
    }
  • 相关阅读:
    Scheduler踩坑记录
    关于RedisTemplate的map存储踩坑记录
    关于HashMap的加载因子相关理解
    Mybatis 分页插件PageHelper 遇坑
    Linux 下 Mysql忘记密码重置
    Eclipse MAT和jvisualvm分析内存溢出
    使用jdk自带工具jvisualvm 分析内存dump文件
    EUREKA 删除 or 强制下线/上线 实例
    Idea 远程调试jenkins 项目
    spring 事务传播行为类型
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2710915.html
Copyright © 2020-2023  润新知