• HDU Super Jumping! Jumping! Jumping!


    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 156 Accepted Submission(s): 97
    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     
    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the maximum according to rules, and one line one case.
     
    Sample Input
    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0
     
    Sample Output
    4
    10
    3
    状态转移方程为:f[i] = max(f[k]+num[i]),1 <=k<i;
     
    #include <iostream>

    using namespace
    std;

    int
    main()
    {

        int
    N,num[1001],f[1001],max;
        while
    (cin>>N&&N)
        {

            //max = 0;
            cin>>num[1];

            f[1] = num[1];
            max = num[1];
            for
    (int i = 2; i <=N ; i++)
            {

                cin>>num[i];
                f[i] = num[i];
                for
    (int j = 1; j < i ; j++)
                {

                    if
    (num[i]>num[j])
                    {

                        if
    (f[i]<f[j]+num[i
    ])

                        {


                            f[i] = f[j] + num[i];
                                   if
    (f[i]>max)

                           max = f[i];
                        }
                    }
                }
            }

            cout<<max<<endl;
        }

        return
    0;
    }

  • 相关阅读:
    CentOS 6.3 安装 phpmyadmin
    mysql 常用命令
    用PHP将Unicode 转化为UTF-8
    Angularjs通过$http与服务器通信
    话说Angularjs的$resource模块
    AngularCSS--关于angularjs动态加载css文件的方法(仅供参考)
    Angular-ui-router + oclazyload + requirejs实现资源随route懒加载
    移动前端开发之viewport的深入理解
    AngularJS的ng-class切换class
    AngularJS中如何对Controller与Service进行分层设计与编码
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2127049.html
Copyright © 2020-2023  润新知