• hdu Count the Trees


    Count the Trees

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 135 Accepted Submission(s): 102
    Problem Description
    Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.
    Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

    For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.

    If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

     
    Input
    The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.
     
    Output
    For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.
     
    Sample Input
    1
    2
    10
    25
    0
     
    Sample Output
    1
    4
    60949324800
    75414671852339208296275849248768000000
     
     
    给定n个元素,求组成的树的不同的结构的个数。
          分析:元素的排列方式为n!种,树的结构不同形式为卡特兰数C(n),
          所以:总共的数的不同结构为n!*C(n);

    import java.util.*;

    import java.math.*;
    public class
    Main {

        public static
    void main(String[] args){
        Scanner
    cin = new Scanner(System.in);
        BigDecimal
    []a = new BigDecimal[101];
        BigDecimal
    []kt = new BigDecimal[101];
        BigDecimal
    b,n;
        int
    k;

        a[0] = BigDecimal.valueOf(1);
        for
    (int i = 1 ; i < 101;i++){

           b = a[i-1].multiply(BigDecimal.valueOf(i));
           a[i] = b;
        }

        kt[1] = BigDecimal.valueOf(1);
        for
    (int i = 2;i< 101;i++){

        n = BigDecimal.valueOf(i);
        b = BigDecimal.valueOf(4).multiply(n);
        b = b.subtract(BigDecimal.valueOf(2));
        n = n.add(BigDecimal.valueOf(1));
        b = b.multiply(kt[i-1]);
        kt[i] = b.divide(n);
        }

          while
    (cin.hasNext()){

          k = cin.nextInt();
          if
    (k==0)break;

          b = a[k].multiply(kt[k]);
          System
    .out.println(b);
          }
        }
    }

  • 相关阅读:
    Sqlite 语句 记录
    string.Format对C#字符串格式化
    C#耗时计算
    控件缩放
    C# winfrom Datagridview表头样式和选中样式
    C# winfrom Datagridview控件下拉菜单
    C# 平台问题
    编程思想
    强制删除sql用户链接
    MyEclipse快捷键大全
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2122522.html
Copyright © 2020-2023  润新知