• Box of Bricks


    Box of Bricks

    Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1450 Accepted Submission(s): 335
    Problem Description
    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I\'ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
     
    Input
    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.
     
    Output

                For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
    Output a blank line between each set.
     
    Sample Input
    6
    5 2 4 1 7 5
    0
     
    Sample Output
    Set #1
    The minimum number of moves is 5.
    • Code Render Status : Rendered By HDOJ G++ Code Rander Version 0.01 Beta
    #include <iostream>
    #include "string.h"
    using namespace std;
    int main()
    {
      int set=0,num,hi[101],total,mv;
        while( cin>>num&&num!=0)
        {
            mv = 0 ;
            total = 0 ;
            memset(hi,0,sizeof(hi));
    
             for(int i = 0 ; i < num ; i++)
          {
              cin>>hi[i];
              total +=hi[i];
          }
          int k = total/num;
          for(int i = 0 ; i < num ; i++)
          {
              if(hi[i]>k) mv += (hi[i]-k);
          }
          set++;
          cout<<"Set #"<<set<<endl;
          cout<<"The minimum number of moves is "<<mv<<"."<<endl<<endl;
        }
          return 0;
    }
  • 相关阅读:
    分布式机器学习:算法、理论与实践——【1】
    LLVM Cookbook
    【前端】Webpack 进阶
    Noip2015 运输计划 树上差分 二分答案
    bzoj 2259: [Oibh]新型计算机 最短路 建模
    888E
    [ZJOI2012]旅游 对偶图 树的直径
    [HAOI2007]理想的正方形 单调队列 暴力
    bzoj1457: 棋盘游戏 SG函数 Nim
    Bomb HDU
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2114932.html
Copyright © 2020-2023  润新知