• BZOJ 3942: [Usaco2015 Feb]Censoring


    3942: [Usaco2015 Feb]Censoring

    Time Limit: 10 Sec  Memory Limit: 128 MB
    Submit: 404  Solved: 221
    [Submit][Status][Discuss]

    Description

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

    FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

    Please help FJ determine the final contents of S after censoring is complete

    有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

    
    
    

    Input

    The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
     

    Output

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

    
    
    

    Sample Input

    whatthemomooofun
    moo

    Sample Output

    whatthefun

    HINT

     

    Source

    分析:

    就是维护一个栈,然后如果栈顶出现了t,弹出t,继续匹配,用kmp加速匹配过程...

    代码:

    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    //by NeighThorn
    using namespace std;
    
    const int maxn=1000000+5;
    
    int n,m,tail,nxt[maxn],stk[maxn];
    
    char s[maxn],t[maxn],ans[maxn];
    
    inline void getnxt(void){
    	nxt[0]=nxt[1]=0;int k;
    	for(int i=1;i<n;i++){
    		k=nxt[i];
    		while(k&&t[k+1]!=t[i+1])
    			k=nxt[k];
    		if(t[k+1]==t[i+1])
    			nxt[i+1]=k+1;
    		else
    			nxt[i+1]=0;
    	}
    }
    
    inline void kmp(void){
    	tail=0;int i=1;
    	for(int i=1;i<=n;i++){
    		ans[++tail]=s[i];
    		int j=stk[tail-1];
    		while(j&&t[j+1]!=s[i])
    			j=nxt[j];
    		if(s[i]==t[j+1])
    			j++;
    		stk[tail]=j;
    		if(j==m)
    			tail-=m;
    	}
    }
    
    signed main(void){
    	scanf("%s%s",s+1,t+1);
    	n=strlen(s+1);m=strlen(t+1);
    	getnxt();kmp();
    	for(int i=1;i<=tail;i++)
    		printf("%c",ans[i]);puts("");
    	return 0;
    }
    

      


    By NeighThorn

  • 相关阅读:
    java 环境变量配置
    框架分成介绍
    Net 新特性
    一 设计模式六大原则
    web api 配置
    Visual Studio检查内存泄露方法
    深度比较对象的不同
    reportview 安装使用
    Nuget 常用命令
    freeswitch学习笔记
  • 原文地址:https://www.cnblogs.com/neighthorn/p/6404277.html
Copyright © 2020-2023  润新知