• 杭电 搜索 水题1072 Nightmare


    Nightmare

    Problem Description
    Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

    Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

    Here are some rules:
    1. We can assume the labyrinth is a 2 array.
    2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
    3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
    4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
    5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
    6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. There are five integers which indicate the different type of area in the labyrinth: 0: The area is a wall, Ignatius should not walk on it. 1: The area contains nothing, Ignatius can walk on it. 2: Ignatius’ start position, Ignatius starts his escape from this position. 3: The exit of the labyrinth, Ignatius’ target position. 4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

    Sample Input
    3
    3 3
    2 1 1
    1 1 0
    1 1 3
    4 8
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1
    1 0 0 0 0 0 0 1
    1 1 1 4 1 1 1 3
    5 8
    1 2 1 1 1 1 1 4
    1 0 0 0 1 0 0 1
    1 4 1 0 1 1 0 1
    1 0 0 0 0 3 0 1
    1 1 4 1 1 1 1 1

    Sample Output
    4
    -1
    13

    #include<iostream>
    #include<algorithm>
    #include<queue>
    #include<cstring>
    using namespace std;
    struct node
    {
        int a,b,num,st;
    }as,t,h;
    int k,l,n,m;
    int w[10][10];
    int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    void dfs()
    {
        queue<node>q;
        q.push(h);
        while(!q.empty())
        {
            as=q.front();
            q.pop();
            for(int i=0;i<4;i++)
            {
                t.a=as.a+dir[i][0];
                t.b=as.b+dir[i][1];
                t.num=as.num-1;
                t.st=as.st+1;
                if(t.a>=0&&t.a<n&&t.b>=0&&t.b<m&&t.num>0)
                {
                     if(w[t.a][t.b]==3&&t.num>0)
                    {
                        cout<<t.st<<endl; return ;
                    }
                    else if(w[t.a][t.b]==4)//当走到炸弹复位设备地方时间 时间重置为6 且 将w【】【】重置成0
                    {
                        t.num=6;
                        w[t.a][t.b]=0;//避免陷入死循环
                        q.push(t);
                    }
                    else if(w[t.a][t.b]==1)
                    {
                        q.push(t);
                    }
                }
            }
        }
        cout<<"-1"<<endl;
        return ;
    }
    int main()
    {
        cin>>l;
        while(l--)
        {
            cin>>n>>m;
            memset(w,0,sizeof(w));
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    cin>>w[i][j];
                    if(w[i][j]==2)
                    {
                        h.a=i;
                        h.b=j;
                        h.num=6;
                        h.st=0;
                    }
                }
            }
            dfs();
        }
        return 0;
    }
    
  • 相关阅读:
    服务器监控
    Ubuntu16.04安装印象笔记
    在vi中打开多个文件,复制一个文件中多行到另一个文件中
    Ubuntu16.04安装和卸载MySQL 5.7
    Ubuntu16.04 sever 安装
    查看ubuntu 各系统的内核版本
    Ubuntu16.04中查看硬盘的型号和读取速度
    python 实现3-2 问候语: 继续使用练习 3-1 中的列表,但不打印每个朋友的姓名,而为每人打印一条消息。每条消息都包含相同的问候语,但抬头为相应朋友的姓名。
    线程
    并发编程
  • 原文地址:https://www.cnblogs.com/nanfenggu/p/7900182.html
Copyright © 2020-2023  润新知