• HDU 2141 Can you find it?(二分)


    Can you find it?

    Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
    Total Submission(s): 33248 Accepted Submission(s): 8241

    Problem Description
    Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

    Input
    There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

    Output
    For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

    Sample Input
    3 3 3
    1 2 3
    1 2 3
    1 2 3
    3
    1
    4
    10
    
    
    Sample Output
    Case 1:
    NO
    YES
    NO
    
    
    Author
    wangye
    
    
    Source
    HDU 2007-11 Programming Contest
    
    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<math.h>
    using namespace std;
    int main()
    {
        long long l,m,n,cnt=1;
        while(cin>>l>>m>>n)
        {
        long long a[510],b[510],c[510],num[250010];
        for(int i=0;i<l;i++)//输入三个数组 
        cin>>a[i];
        for(int i=0;i<m;i++)
        cin>>b[i];
        for(int i=0;i<n;i++)
        cin>>c[i];
        int k=0;
        for(int i=0;i<l;i++)
            for(int j=0;j<m;j++)
                num[k++]=a[i]+b[j];//前两个数组两两相加得到新数组 
        sort(num,num+k);//从小到大排序 
        int s;
        cin>>s;
        cout<<"Case "<<cnt++<<":"<<endl;//输出第几个测试实例 
        while(s--)
        {
            long long x;
            cin>>x;
            bool st =false;
            for(int i=0;i<n;i++)//第三个数组和新数组mid相加判断 
            {
            int l=0,r=k-1;
            while(l<=r)
            {
                int mid=(l+r)>>1;
                if(num[mid]+c[i]==x)
                {
                    st=true;
                    break;
                }
                else if(num[mid]+c[i]<x)
                    l=mid+1;
                else
                    r=mid-1;
            }   
            if(st)
                break;
            }
            if(st)
            cout<<"YES"<<endl;
            else
            cout<<"NO"<<endl;
        }   
        }
        return 0;
    }
  • 相关阅读:
    南阳oj 814 又见拦截导弹
    南阳 zb的生日和邮票分你一般(01背包思路)
    导弹拦截(最长下降子序列)变形
    控件绝对定位函数
    小玩意
    java获取本机所有可用字体
    按键监听类KeyListener及适配器改良方案
    编译php-memcached扩展
    Memcached安装,启动,连接
    Apache配置虚拟主机
  • 原文地址:https://www.cnblogs.com/nanfenggu/p/7899986.html
Copyright © 2020-2023  润新知