• HDU 2391 Filthy Rich(dp)


    Filthy Rich

    Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3736 Accepted Submission(s): 1658

    Problem Description
    They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

    Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.

    Input
    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
    The maximum amount of gold will always fit in an int.

    Output
    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.

    Sample Input
    1
    3 4
    1 10 8 8
    0 0 1 8
    0 27 0 4
    
    
    Sample Output
    Scenario #1:
    42
    

    简单dp 主要是能想到用dp去求解

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int dp[1010][1010];
    int main()
    {
    
        int t,n,m,k=0;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d",&n,&m);
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=m;j++)
                {
                    scanf("%d",&dp[i][j]);
                    dp[i][j]+=max(dp[i-1][j],dp[i][j-1]);
                }
            }
            printf("Scenario #%d:
    %d
    
    ",++k,dp[n][m]);
        }
        return 0;
    }
  • 相关阅读:
    vue 兼容IE报错解决方案
    JDK1.8 ArrayList 源码解析
    Mac nasm 汇编入门
    命令模式
    模板方法
    Mysql Limit 调优
    观察者模式
    外观模式
    Rest- Client
    MongoDB数据库 5分钟快速上手
  • 原文地址:https://www.cnblogs.com/nanfenggu/p/7899983.html
Copyright © 2020-2023  润新知