• POJ 3020 Antenna Placement 最大匹配


    Antenna Placement
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6445   Accepted: 3182

    Description

    The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

    Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?



    Input

    On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.

    Output

    For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

    Sample Input

    2
    7 9
    ooo**oooo
    **oo*ooo*
    o*oo**o**
    ooooooooo
    *******oo
    o*o*oo*oo
    *******oo
    10 1
    *
    *
    *
    o
    *
    *
    *
    *
    *
    *
    

    Sample Output

    17
    5


    无向二分图的最小路径覆盖 = 顶点数 – 最大二分匹配数/2

    #include<iostream>
    #include<cstring>
    using namespace std;
    
    #define M 405
    int a[M][M],b[M][M];
    int p;
    int v[M],f[M];
    int w[4][2]={0,1,0,-1,1,0,-1,0};
    
    int fi(int x)
    {
    	for(int i=1;i<=p;i++)
    		if(!v[i] && b[x][i])
    		{
    			v[i]=1;
    			if(!f[i] || fi(f[i]))
    			{
    				f[i]=x;
    				return 1;
    			}
    		}
    	return 0;
    }
    
    int main()
    {
    	int T;
    	cin>>T;getchar();
    	while(T--)
    	{		
    		memset(a,0,sizeof(a));
    		memset(b,0,sizeof(b));
    		memset(f,0,sizeof(f));
    		int n,m;
    		cin>>n>>m;
    		int i,j;
    		char c;
    
    		p=0;
    		for(i=1;i<=n;i++)
    		{
    			for(j=1;j<=m;j++)
    			{
    				cin>>c;
    				if(c=='*')
    					a[i][j]=++p;
    			}
    			getchar();
    		}
    
    		for(i=1;i<=n;i++)
    			for(j=1;j<=m;j++)
    				if(a[i][j])   for(int q=0;q<4;q++)
    				{
    					int x=i+w[q][0];
    					int y=j+w[q][1];
    					if(a[x][y])
    						b[a[i][j]][a[x][y]]=1;
    				}
    
    		int sum=0;
    		for(i=1;i<=p;i++)
    		{
    			memset(v,0,sizeof(v));
    			if(fi(i))   sum++;
    		}
    		
    		cout<<p-sum/2<<endl;
    	}
    
    	return 0;
    }
    


  • 相关阅读:
    POJ 2411 状态压缩递,覆盖方案数
    POJ 2774 最长公共子串
    POJ 1743 不可重叠的最长重复子串
    POJ 3294 出现在至少K个字符串中的子串
    POJ 3261 出现至少K次的可重叠最长子串
    POJ 1741/1987 树的点分治
    HDU1556 Color the ball
    解决linux系统时间不对的问题
    CentOS 6.9使用Setup配置网络(解决dhcp模式插入网线不自动获取IP的问题)
    Linux网络配置(setup)
  • 原文地址:https://www.cnblogs.com/mqxnongmin/p/10960669.html
Copyright © 2020-2023  润新知