• 1118 Birds in Forest (25 分)(并查集)


    Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
    K B1 B2 ... BK
    where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

    After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

    Output Specification:

    For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

    Sample Input:

    4
    3 10 1 2
    2 3 4
    4 1 5 7 8
    3 9 6 4
    2
    10 5
    3 7

    Sample Output:

    2 10
    Yes
    No

    题目大意:

    一幅画里面的鸟为同一棵树上的,问有多少棵树和多少只鸟,以及对于两只鸟判断是否在同一个树上~

    分析:

    使用并查集就可以啦将一幅画中鸟使用Union函数合并在同一个集合里面,cnt[i]数组保存以i为FindFather结点的集合里面的鸟的个数,exist[i]表示鸟的id——i在输入的鸟的序号里面是否出现过,遍历cnt数组并累加所有不为0的个数即可得知有多少棵树,累加所有出现过的鸟的id的cnt的值即可得知鸟的个数判断两只鸟是否在同一棵树,只需要知道这两只鸟的findFather是否相等即可~~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52505109

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    int father[10000],vis[10000],isRoot[10000];
    int findFather(int x){
        while(x!=father[x]){
            x=father[x];
        }
        return x;
    }
    void Union(int a,int b){
        int faA=findFather(a);
        int faB=findFather(b);
        if(faA>faB)
            father[faA]=faB;
        else if(faA<faB)
            father[faB]=faA;
    }
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,tmp,k,cnt=0,birds=0;
        cin>>n;
        for(int i=1;i<=10000;i++){
            father[i]=i;
        }
        int id, temp;
        for(int i = 0; i < n; i++) {
            scanf("%d%d", &k, &id);
            vis[id] = true;
    	//这里是选取第一个为union的左,剩余的k-1个依次为union的右
            for(int j = 0; j < k-1; j++) {
                scanf("%d", &temp);
                Union(id, temp);
                vis[temp] = true;
            }
        }
        for(int i=1;i<=10000;i++){
            if(vis[i]){
                isRoot[findFather(i)]++;
                birds++;
            }
        }
        for(int i=1;i<=10000;i++){
            if(vis[i]&&isRoot[i]){
                cnt++;
            }
        }
        //sort(isRoot,isRoot+10000,greater<int>());
        cout<<cnt<<" "<<birds<<endl;
        int query,a,b;
        cin>>query;
        while(query--){
            cin>>a>>b;
            int faa=findFather(a);
            int fab=findFather(b);
            if(faa==fab)
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    [转]K/3加密控制规则
    修改Delphi2009的界面风格
    [转]软件版本号讲解: 什么是Alpha, Beta, RC
    百度程序题目连续数问题
    得到正整数a的16进制表示
    四舍五入至某小数位后返回数字串
    返回相同宽度数字型字符串
    百度程序题目连续数问题 另解
    求二进制表示中1的个数
    六支筷子取其二,恰为一双的概率
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15956057.html
Copyright © 2020-2023  润新知