• 1114 Family Property (25 分)(并查集)


    This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

    ID Father Mother k Child1 ... Childk M_estate Area

    where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

    Output Specification:

    For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

    ID M AVG_sets AVG_area

    where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

    Sample Input:

    10
    6666 5551 5552 1 7777 1 100
    1234 5678 9012 1 0002 2 300
    8888 -1 -1 0 1 1000
    2468 0001 0004 1 2222 1 500
    7777 6666 -1 0 2 300
    3721 -1 -1 1 2333 2 150
    9012 -1 -1 3 1236 1235 1234 1 100
    1235 5678 9012 0 1 50
    2222 1236 2468 2 6661 6662 1 300
    2333 -1 3721 3 6661 6662 6663 1 100

    Sample Output:

    3
    8888 1 1.000 1000.000
    0001 15 0.600 100.000
    5551 4 0.750 100.000

    题目大意:

    给定每个人的家庭成员和其自己名下的房产,请你统计出每个家庭的人口数、人均房产面积及房产套数。首先在第一行输出家庭个数(所有有亲属关系的人都属于同一个家庭)。随后按下列格式输出每个家庭的信息:家庭成员的最小编号 家庭人口数 人均房产套数 人均房产面积。其中人均值要求保留小数点后3位。家庭信息首先按人均面积降序输出,若有并列,则按成员编号的升序输出

    分析:

    用并查集。分别用两个结构体数组,一个data用来接收数据,接收的时候顺便实现了并查集的操作union,另一个数组ans用来输出最后的答案,因为要计算家庭人数,所以用visit标记所有出现过的结点,对于每个结点的父结点,people++统计人数。标记flag == true,计算true的个数cnt就可以知道一共有多少个家庭。排序后输出前cnt个就是所求答案~~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52200109

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    struct Data
    {
        int id,fid,mid,num,area;
        int cid[10];
    }Data[1005];
    struct node
    {
        int id,people;
        double num,area;
        bool flag=false;
    }ans[10000];
    int father[10000],vis[10000];
    int findFather(int x){
        while(x!=father[x]){
            x=father[x];
        }
        return x;
    }
    void Union(int a,int b){
        int faA=findFather(a);
        int faB=findFather(b);
        if(faA>faB)
            father[faA]=faB;
        else if(faA<faB)
            father[faB]=faA;
    }
    bool cmp(node a,node b){
        if(a.area!=b.area) return a.area>b.area;
        else return a.id<b.id;
    }
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,k;
        cin>>n;
        for(int i=0;i<10000;i++){
            father[i]=i;
        }
        for(int i=0;i<n;i++){
            cin>>Data[i].id>>Data[i].fid>>Data[i].mid>>k;
            vis[Data[i].id]=true;
            if(Data[i].fid!=-1){
                Union(Data[i].id,Data[i].fid);
                vis[Data[i].fid];
            }
            if(Data[i].mid!=-1){
                Union(Data[i].id,Data[i].mid);
                vis[Data[i].mid];
            }
            for(int j=0;j<k;j++){
                cin>>Data[i].cid[j];
                Union(Data[i].id,Data[i].cid[j]);
                vis[Data[i].cid[j]]=true;
            }
            cin>>Data[i].num>>Data[i].area;
        }
        for(int i=0;i<n;i++){
            int id=findFather(Data[i].id);
            ans[id].id=id;
            ans[id].num+=Data[i].num;
            ans[id].area+=Data[i].area;
            ans[id].flag=true;
        }
        int cnt=0;
        for(int i=0;i<10000;i++){
            if(vis[i]=true)
                ans[findFather(i)].people++;
            if(ans[i].flag==true)
                cnt++;
        }
        for(int i=0;i<10000;i++){
            if(ans[i].flag){
                ans[i].num=(double)(ans[i].num*1.0/ans[i].people);
                ans[i].area=(double)(ans[i].area*1.0/ans[i].people);
            }
        }
        sort(ans,ans+10000,cmp);
        cout<<cnt<<endl;
        for(int i=0;i<cnt;i++){
            printf("%04d %d %.3f %.3f\n",ans[i].id,ans[i].people,ans[i].num,ans[i].area);
        }
        return 0;
    }
    
  • 相关阅读:
    解决phpcms图片太大撑破表格图片自适应图片按比例缩小
    CSS代码使纯英文数字自动换行
    CSS网页布局错位:CSS宽度计算
    CSS控制div宽度最大宽度/高度和最小宽度/高度
    鼠标HOVER时区块动画旋转变色的CSS3样式掩码
    记录--正则表达式
    写在前面
    ruby Mixin用法
    ruby 模块 的引入
    ruby 编写迭代器
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15955526.html
Copyright © 2020-2023  润新知