• 1142 Maximal Clique (25 分)(图论,无向完全图)


    A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))
    Now it is your job to judge if a given subset of vertices can form a maximal clique.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
    After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

    Output Specification:

    For each of the M queries, print in a line "Yes" if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print "Not Maximal"; or if it is not a clique at all, print "Not a Clique".

    Sample Input:

    8 10
    5 6
    7 8
    6 4
    3 6
    4 5
    2 3
    8 2
    2 7
    5 3
    3 4
    6
    4 5 4 3 6
    3 2 8 7
    2 2 3
    1 1
    3 4 3 6
    3 3 2 1

    Sample Output:

    Yes
    Yes
    Yes
    Yes
    Not Maximal
    Not a Clique

    生词

    英文 解释
    clique 小集*、*系

    题目大意:

    clique是一个点集,在一个无向图中,这个点集中任意两个不同的点之间都是相连的。maximal clique是一个clique,这个clique不可以再加入任何一个新的结点构成新的clique。点编号从1~nv,给出ne条边,以一对结点编号的方式给出。然后给出m条询问,每个询问是一个点集合,问这个点集合是否是maximal clique、是否是clique~

    分析:

    先判断是否是clique,即判断是否任意两边都相连;之后判断是否是maximal,即遍历所有不在集合中的剩余的点,看是否存在一个点满足和集合中所有的结点相连,最后如果都满足,那就输出Yes表示是Maximal clique~

    原文链接:https://blog.csdn.net/liuchuo/article/details/79618797

    题解

    题目逻辑
    1.判断是否为clique:若是,则转入2;否则直接输出Not a Clique结束。
    2.判断是否为maximal:若是,则输出Yes;否则输出Not Maximal(是clique不是maximal)。
    判断逻辑
    1.判断clique:点集中所有不同的点是否全相连。
    2.判断maximal:遍历不在点集中剩余的点,看 是否与 点集 中的点全不相连

    #include <bits/stdc++.h>
    
    using namespace std;
    int nv,ne;
    int e[210][210];
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int a,b;
        cin>>nv>>ne;
        for(int i=0;i<ne;i++){
            cin>>a>>b;
            e[a][b]=e[b][a]=1;
        }
        int m,k;
        cin>>m;
        while(m--){
            cin>>k;
            vector<int> v(k);
            int hash[210]={0};
            int isclique=1,ismaximal=1;
            for(int i=0;i<k;i++){
                cin>>v[i];
                hash[v[i]]=1;
            }
            for(int i=0;i<k-1;i++){
                if(isclique==0) break;
                for(int j=i+1;j<k;j++){
                    if(e[v[i]][v[j]]==0){
                        isclique=0;
                        cout<<"Not a Clique"<<endl;
                        break;
                    }
                }
            }
            if(isclique==0) continue;
            for(int i=1;i<=nv;i++){
                if(hash[i]==0){
                    for(int j=0;j<k;j++){
                        if(e[i][v[j]]==0) break;
                        if(j==k-1) ismaximal=0;
                    }
                }
                if(ismaximal==0){
                    cout<<"Not Maximal"<<endl;
                    break;
                }
            }
            if(ismaximal==1) cout<<"Yes"<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    cocos代码研究(24)Widget子类PageView学习笔记
    cocos代码研究(23)Widget子类ScrollView学习笔记
    cocos代码研究(22)Widget子类Layout学习笔记
    JavaScript:学习笔记(5)——箭头函数=>以及实践
    顽石系列:CSS实现垂直居中的五种方法
    算法:红黑树
    Vue:实践学习笔记(3)——组件使用
    Java进阶学习:将文件上传到七牛云中
    LeetCode:下一个排列【31】
    Linux:Ubuntu下部署Web运行环境
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15942497.html
Copyright © 2020-2023  润新知