• 1029 Median (25 分)(two pointers)


    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output

    For each test case you should output the median of the two given sequences in a line.

    Sample Input

    4 11 12 13 14
    5 9 10 15 16 17

    Sample Output

    13

    题目大意:

    给出两个已排序序列,求这两个序列合并后的中间数

    分析:

    既然两个数组都是递增的顺序,可以借助归并的思想~与归并排序不同的是,在第一个while里如果找到了中位数,就直接跳出来~

    如果其中一个数组已经走到头也没有找到中位数,可以用数学公式直接推导出中位数在另一个数组中的位置~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52221378

    题解

    比较简单的暴力解法

    #include<bits/stdc++.h>
    using namespace std;
    int main() {
    	//freopen("input.txt", "r", stdin); //提交时把这行注释掉就行
    	int n, m;
    	cin >> n;
    	vector<int>s1(n);
    	for (int i = 0; i < n; i++)
    		scanf("%d", &s1[i]);
    	cin >> m;
    	s1.resize(n + m);
    	for (int i = n; i < n + m; i++)
    		scanf("%d", &s1[i]);
    	sort(s1.begin(), s1.end());
    	printf("%d", s1[(n + m - 1) / 2]);
    	return 0;
    }
    
  • 相关阅读:
    CSS使用规则总结
    python虚拟机内存泄露?
    对象内存池
    由引擎接口自顶向下的设计引擎结构
    【译】Lesson 0: 开始学习WebGL
    【译】Lesson 1: 一个三角形和一个方块
    网盘中搭建git服务
    行为树(Behavior Tree)
    显卡参数大全
    VTune 备忘
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15851478.html
Copyright © 2020-2023  润新知