• 1152 Google Recruitment (20 分)(字符串处理)


    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
    image

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819

    Sample Output 1:

    49877

    Sample Input 2:

    10 3
    2468024680

    Sample Output 2:

    404

    生词

    英文 解释
    consecutive 连续的
    recruitment 招收
    hiring process 招聘流程

    题目大意:

    给出一个l长度的字符串,求出其中第一个k位的素数

    分析:

    枚举每个k位的子串,转换成整数,判断是否是素数(判断素数的时候要把0和1也考虑进去)~

    原文链接:https://blog.csdn.net/liuchuo/article/details/84973085

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    bool prime(int n)
    {
        if(n<=1) return false;
        for(int i=2;i*i<=n;i++){
            if(n%i==0) return false;
        }
        return true;
    }
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int l,k;
        string n;
        cin>>l>>k;
        cin>>n;
        for(int i=0;i<n.size()-k+1;i++){
            int x=stoi(n.substr(i,k));
            if(prime(x)){
                cout<<n.substr(i,k);
                return 0;
            }
        }
        cout<<404;
        return 0;
    }
    
  • 相关阅读:
    用上帝视角来看待组件的设计模式
    npm和package.json那些不为常人所知的小秘密
    四步走查智能硬件异常Case
    PorterDuffXfermode 图像混合技术在漫画APP中的应用
    发布流程进化史
    二叉搜索树的操作集
    02-线性结构1 两个有序链表序列的合并
    07-图6 旅游规划
    树的同构
    线性结构4 Pop Sequence
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15844599.html
Copyright © 2020-2023  润新知