• 1105 Spiral Matrix (25 分)(模拟)


    This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:

    12
    37 76 20 98 76 42 53 95 60 81 58 93

    Sample Output:

    98 95 93
    42 37 81
    53 20 76
    58 60 76

    生词

    英文 解释
    Spiral Matrix 旋转矩阵
    clockwise 顺时针的

    题目大意:

    将给定的N个正整数按非递增的顺序,填入“螺旋矩阵”所谓“螺旋矩阵”,是指从左上角第1个格子开始,按顺时针螺旋方向填充要求矩阵的规模为m行n列,满足条件:m*n等于N;m>=n;且m-n取所有可能值中的最小值~

    分析:

    先计算行数m和列数n的值,n从根号N的整数部分开始,往前推一直到1,找到第一个满足N % n== 0的,m的值等于N/n~将N个给定的值输入数组a,并将a数组中的值按非递增排序,接着建立m行n列的数组b,填充时按层数填充,一个包裹矩阵的口字型为一层,计算螺旋矩阵的层数level,如果m的值为偶数,层数为m/2,如果m为奇数,层数为m/2+1,所以level = m / 2 + m % 2;因为是从左上角第1个格子开始,按顺时针螺旋方向填充,所以外层for循环控制层数i从0到level,内层for循环按左上到右上、右上到右下、右下到左下、左下到左上的顺序一层层填充,注意内层for循环中还要控制t <= N – 1,因为如果螺旋矩阵中所有的元素已经都填充完毕,就不能再重复填充~填充完毕后,输出整个矩阵~
    image

    原文链接:https://blog.csdn.net/liuchuo/article/details/52123228

    柳神题解

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    using namespace std;
    int cmp(int a, int b) {return a > b;}
    int main() {
        int N, m, n, t = 0;
        scanf("%d", &N);
        for (n = sqrt((double)N); n >= 1; n--) {
            //if语句>=2加大括号,抄错了的原因Orz
            if (N % n == 0) {
                m = N / n;
                break;
            }
        }
        vector<int> a(N);
        for (int i = 0; i < N; i++)
            scanf("%d", &a[i]);
        sort(a.begin(), a.end(), cmp);
        vector<vector<int> > b(m, vector<int>(n));
        int level = m / 2 + m % 2;
        for (int i = 0; i < level; i++) {
            for (int j = i; j <= n - 1 - i && t <= N - 1; j++)
                    b[i][j] = a[t++];
            for (int j = i + 1; j <= m - 2 - i && t <= N - 1; j++)
                    b[j][n - 1 - i] = a[t++];
            for (int j = n - i - 1; j >= i && t <= N - 1; j--)
                    b[m - 1 - i][j] = a[t++];
            for (int j = m - 2 - i; j >= i + 1 && t <= N - 1; j--)
                    b[j][i] = a[t++];
        }
        for (int i = 0; i < m; i++) {
            for (int j = 0 ; j < n; j++) {
                printf("%d", b[i][j]);
                if (j != n - 1) printf(" ");
            }
            printf("\n");
        }
        return 0;
    }
    
  • 相关阅读:
    获取某个文件夹下面的子文件夹(要求是第一级)
    操作手册
    GWT与GXT
    eclipse中出现:The project cannot be built until build path errors are resolved
    eclipse部署项目要做的工作及配置
    如何测试tomcat安装成功
    tomcat的安装及eclipse配置
    配置jdk
    oracle数据库的安装、完全卸载与plsql的安装以及与oracle的连接
    UVA
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15760455.html
Copyright © 2020-2023  润新知