• 1054 The Dominant Color (20 分)(map)


    Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, simply print the dominant color in a line.

    Sample Input:

    5 3
    0 0 255 16777215 24
    24 24 0 0 24
    24 0 24 24 24
    

    Sample Output:

    24

    生词

    英文 解释
    proportional 成比例的
    dominant 主导的
    resolution 分辨率

    题目大意:

    选取主色调,就是M列N行的矩阵里面出现次数多余一半的那个数字~

    分析:

    STL中map的应用~使用arr[i] = j表示i元素在矩阵中出现了j次,在输入的同时比较arr当前的值是否已经超过半数,如果超过,就直接输出该数字并退出程序~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52118849

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    map<string,int> pix;
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int m,n;
        string s;
        cin>>m>>n;
        for(int i=0;i<n;i++){
           for(int j=0;j<m;j++){
                cin>>s;
                pix[s]++;
           }
        }
        for(auto it=pix.begin();it!=pix.end();it++){
            if(it->second>m*n/2)
                cout<<it->first<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    路由
    客户端如何调用
    第一个简单的DEMO
    Web API初印象
    项目开发中经常使用的缓存
    EF的Model First
    如何计算代码的运行性能
    使用Obsolete特性来标记方法过时或弃用
    nodeJs实现文件上传,下载,删除
    node 部署教程二
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15585034.html
Copyright © 2020-2023  润新知