• 1048 Find Coins (25 分)(hash)


    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

    Sample Input 1:

    8 15
    1 2 8 7 2 4 11 15

    Sample Output 1:

    4 11

    Sample Input 2:

    7 14
    1 8 7 2 4 11 15

    Sample Output 2:

    No Solution

    题目大意:

    给出n个正整数和一个正整数m,问n个数字中是否存在一对数字a和b(a <= b),使a+b=m成立。如果有多个,输出a最小的那一对。

    分析:

    建立数组a保存每个数字出现的次数,然后判断输出

    原文链接:https://blog.csdn.net/liuchuo/article/details/52153248

    hash法

    666~

    #include <iostream>
    using namespace std;
    int a[1001];
    int main() {
        int n, m, temp;
        scanf("%d %d", &n, &m);
        for(int i = 0; i < n; i++) {
            scanf("%d", &temp);
            a[temp]++;
        }
        for(int i = 0; i < 1001; i++) {
            if(a[i]) {
                a[i]--;
                if(m > i && a[m-i]) {
                    printf("%d %d", i, m - i);
                    return 0;
                }
                a[i]++;
            }
        }
        printf("No Solution");
        return 0;
    }
    

    二分法

    image

    #include <bits/stdc++.h>
    
    using namespace std;
    vector<int> v;
    int Bin(int left,int right,int key)
    {
        int mid;
        while(left<=right){
            mid=(left+right)/2;
            if(v[mid]==key) return mid;
            else if(v[mid]>key) right=mid-1;
            else left=mid+1;
        }
        return -1;
    }
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,m,i;
        scanf("%d%d",&n,&m);
        v.resize(n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&v[i]);
        }
        sort(v.begin(),v.end());
        for(i=0; i<n; i++){
            int pos=Bin(0,n-1,m-v[i]);
            if(pos!=-1&&i!=pos){
                printf("%d %d\n",v[i],v[pos]);
                break;
            }
        }
        if(i==n) printf("No Solution\n");
        return 0;
    }
    
  • 相关阅读:
    Jdbc、Mybatis、Hibernate各自优缺点及区别
    java中的线程池原理
    JVN的理解
    "=="和 equals 方法究竟有什么区别?
    nginx基础之【study one】
    C#,WPF中使用多文本显示数据,并对其数据进行关键字高亮等操作
    C#、WPF中如何自定义鼠标样式
    SSM(Spring + Springmvc + Mybatis)框架面试题
    java基础面试题
    C#关于TreeView树在节点数较多时总是会出现闪烁的问题方法记录
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15576487.html
Copyright © 2020-2023  润新知