• 1036 Boys vs Girls (25 分)(查找元素)


    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    

    题目大意:

    给出N个同学的信息,输出女生中的最高分获得者的信息与男生中最低分获得者的信息,并输出他们的分数差。如果不存在女生或者男生,则对应获得者信息处输出Absent,而且差值处输出NA~

    分析:

    用string类型的female和male保存要求的学生的信息,femalescore和malescore处保存男生的最低分和女生的最高分~

    一开始设femalescore为最低值-1,malescore为最高值101,最后根据分值是否为-1或者101来判断是否有相应的女生或者男生~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52119127

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    struct student
    {
        string name,id;
        char gender;
        int grade;
    };
    bool cmp(student a,student b)
    {
        return a.grade>b.grade;
    }
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n;
        cin>>n;
        vector<student> v(n);
        for(int i=0;i<n;i++){
            cin>>v[i].name>>v[i].gender>>v[i].id>>v[i].grade;
        }
        sort(v.begin(),v.end(),cmp);
        int flag=0,gf=0,gm=0;
        for(int i=0;i<n;i++){
            if(v[i].gender=='F'){
                flag=1;
                gf=v[i].grade;
                cout<<v[i].name<<" "<<v[i].id<<endl;
                break;
            }
        }
        if(flag==0) cout<<"Absent"<<endl;
        flag=0;
        for(int i=n-1;i>=0;i--){
            if(v[i].gender=='M'){
                flag=1;
                gm=v[i].grade;
                cout<<v[i].name<<" "<<v[i].id<<endl;
                break;
            }
        }
        if(flag==0) cout<<"Absent"<<endl;
        if(gf!=0&&gm!=0) cout<<gf-gm<<endl;
        else cout<<"NA"<<endl;
        return 0;
    }
    
  • 相关阅读:
    17. Letter Combinations of a Phone Number
    77. Combinations
    90. Subsets II
    78. Subsets
    275. H-Index II
    154. Find Minimum in Rotated Sorted Array II
    153. Find Minimum in Rotated Sorted Array
    树状数组区间查询和单点更新
    树状数组区间查询和单点更新
    最小生成树 kuangbin专题最后一个题
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15563938.html
Copyright © 2020-2023  润新知