• 1024 Palindromic Number (25 分)(大整数相加)


    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:

    67 3

    Sample Output 1:

    484
    2

    Sample Input 2:

    69 3

    Sample Output 2:

    1353
    3

    生词

    英文 解释
    be paired with 与...配对

    题目大意:

    给定一个数字,和允许翻转后相加的次数cnt,求要多少次才能变成一个回文数字,输出那个回文数字和翻转相加了多少次,如果本身就是回文数字就输出0次,如果超过给定的次数cnt了,就输出那个不是回文的结果,并且输出给定的次数cnt

    分析:

    1、会超出long int类型(会有两个点溢出错误),所以用字符串存储,大整数相加
    2、可以通过对字符串翻转后比较来判断是否为回文串

    原文链接:https://blog.csdn.net/liuchuo/article/details/52280891

    13分题解

    乙级类似的题
    发现自己还是用了同样的方法,然后犯了同样的错误:
    如果两个数的和过大,就会报错如下:
    terminate called after throwing an instance of 'std::out_of_range' what(): stoll
    原因:应该是超出了long long int x+y 的范围。

    唯一的进步就是代码越写越短了。

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        string s;
        int k,cnt=0;
        cin>>s>>k;
        while(k--){
            string t=s;
            reverse(s.begin(),s.end());
            if(t==s){
                break;
            }else{
                s=to_string(atoi(s.c_str())+atoi(t.c_str()));
                cnt++;
            }
        }
        cout<<s<<endl;
        cout<<cnt<<endl;
        return 0;
    }
    

    题解

    yeah!!!没有看柳神的答案自己改对啦~

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        string s;
        int k,cnt=0;
        cin>>s>>k;
        while(k--){
            string t=s;
            reverse(s.begin(),s.end());
            if(t==s){
                break;
            }else{
                int flag=0;
                for(int i=s.length()-1;i>=0;i--){
                    int a=s[i]-'0',b=t[i]-'0';
                    a=a+b+flag;
                    flag=0;
                    if(a>=10){
                        flag=1;
                        a-=10;
                    }
                    s[i]=a+'0';
                }
                if(flag==1) s="1"+s;
                //cout<<s<<endl;
                cnt++;
            }
        }
        cout<<s<<endl;
        cout<<cnt<<endl;
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15529205.html

  • 相关阅读:
    DOCKER启动失败Job for docker.service failed because the control process exited with error code. See "syste mctl status docker.service" and "journalctl -xe" for details.
    windows查看系统安装的补丁
    vue生命周期
    VUE 图片上传/剪切(vue-cropper)
    mysql性能优化关键点
    element vue-quill-editor 富文本编辑器 安装使用
    Module build failed: Error: Node Sass version 6.0.0 is incompatible with ^4.0.0.
    npm ERR! 404 You should bug the author to publish it (or use the name yourself!) npm ERR! 404 It was specified as a dependency of 'hr_front_end'
    __WEBPACK_AMD_DEFINE_ARRAY__ is not defined
    利用BERT得到句子的表示向量(pytorch)
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15529205.html
Copyright © 2020-2023  润新知