• UVALIVE 4556 The Next Permutation


    4556 The Next Permutation
    For this problem, you will write a program that takes a (possibly long) string of decimal digits, and
    outputs the permutation of those decimal digits that has the next larger value (as a decimal number)
    than the input number. For example:
    123 -> 132
    279134399742 -> 279134423799
    It is possible that no permutation of the input digits has a larger value. For example, 987.
    Input
    The first line of input contains a single integer P , (1 ≤ P ≤ 1000), which is the number of data sets that
    follow. Each data set is a single line that contains the data set number, followed by a space, followed
    by up to 80 decimal digits which is the input value.
    Output
    For each data set there is one line of output. If there is no larger permutation of the input digits,
    the output should be the data set number followed by a single space, followed by the string ‘BIGGEST’.
    If there is a solution, the output should be the data set number, a single space and the next larger
    permutation of the input digits.
    Sample Input
    3
    1 123
    2 279134399742
    3 987
    Sample Output
    1 132
    2 279134423799
    3 BIGGEST

    題意:操作字符串,通過調整字符串的順序得到一個新的字符串,新的字符串的数值是比原字符串的数大的最小值;

    题解:由于是最小值,我们可以从后往前遍历字符串,当str[i]>str[i-1]时,pos=i-1,此位置就是我们要调整字符串的起始位置(说明我们可以调整顺序使原来的字符串的值增大),然后从我们要截取的字串中找到第一个比上pos大的值交换,然后将字串排序即可,若没有条件满足str[i]>str[i-1],则通过调整字符顺序没有比原串更大的数值。

    #include<stdio.h>
    #include<string.h>
    #include<stack>
    #include<queue>
    #include<iostream>
    #include<algorithm>
    #include<map>
    #include<vector>
    #define PI acos(-1.0)
    using namespace std;
    typedef long long ll;
    int m,n,k,p;
    int ans[1001];
    int dis[500][500];
    int di[4][2]= {{-1,0},{1,0},{0,-1},{0,1}};
    map<ll,ll>::iterator it;
    int main()
    {
        cin>>m;
        while(m--)
        {
            string str;
            cin>>n>>str;
            int pos=-1;
            for(int i=str.size()-1; i>=1; i--)
            {
                if(str[i]>str[i-1])
                {
                    pos=i-1;
                    break;
                }
            }
            if(pos==-1)
            {
                cout<<n<<" "<<"BIGGEST"<<endl;
                continue;
            }
            string s,arr;
            s=str.substr(pos);
            int cnt=s[0];
            for(int i='0'; i<='9'; i++)
            {
    
                if(s.find(i)!=string::npos&&i>cnt)
                {
                    swap(s[0],s[s.find(i)]);
                    break;
                }
            }
            sort(s.begin()+1,s.end());
            cout<<n<<" "<<str.substr(0,pos)<<s<<endl;;
        }
    
    }
    View Code
  • 相关阅读:
    支付宝H5支付---证书模式
    Redis分布式锁
    Docker+Nginx+Ssl
    Java调用函数传递参数到底是值传递还是引用传递
    Mysql索引查询失效的情况
    mysql索引之最左前缀法则
    数据的三大范式以及什么是反三大范式
    SpringMvc的工作流程
    Android 环境搭建
    Python 爬虫: 抓取花瓣网图片
  • 原文地址:https://www.cnblogs.com/moomcake/p/9787756.html
Copyright © 2020-2023  润新知