• Holding Bin-Laden Captive!


    We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
    “Oh, God! How terrible! ”
     


    Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
    Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
    “Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
    You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

    InputInput contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
    OutputOutput the minimum positive value that one cannot pay with given coins, one line for one case.
    Sample Input

    1 1 3
    0 0 0

    Sample Output

    4
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<stack>
    #include<queue>
    #include<iostream>
    #include<map>
    #include<vector>
    #define Inf 0x3f3f3f3f
    #define PI acos(-1.0)
    using namespace std;
    typedef long long ll;
    const int MXAN=300000+10;
    int dp[1234];
    int str[1234];
    int main()
    {
        ll m,n,p,i,j,pos;
        ll a[MXAN];
        ll b[MXAN];
        ll value[4]={0,1,2,5};
        ll num[4];
        while(cin>>num[1]>>num[2]>>num[3])
        {
            if(num[1]+num[2]+num[3]==0)
                break;
            ll m=num[1]*value[1]+num[2]*value[2]+num[3]*value[3];
            for(ll i=0;i<=m;i++)
            {
                a[i]=1;
                b[i]=0;
            }
            a[m+1]=0;
            ll len=value[1]*num[1];
            for(ll i=2;i<=3;i++)
            {
                len+=value[i]*num[i];
                for(ll j=0;j<=len-value[i]*num[i];j++)
                {
                    for(ll k=0;k+j<=len;k+=value[i])
                    {
                        b[k+j]+=a[j];
                    }
                }
                for(ll j=0;j<=len;j++)
                {
                    a[j]=b[j];
                    b[j]=0;
                }
            }
            for(ll i=0;i<=10200;i++)
            {
                if(a[i]==0)
                {
                    cout<<i<<endl;
                    break;
                }
            }
    
        }
        return 0;
    }


  • 相关阅读:
    centos7不能上网问题
    数据库修改为utf8mb4
    查看Linux系统信息
    如何查看Linux是否安装了gcc和gcc-c++
    nginx启动报错
    centos7无法上网问题
    notepad++如何将换行替换成其它符号?
    JAVA DESUtils加密工具
    Django之Model(一)--基础篇
    深刻理解Python中的元类(metaclass)以及元类实现单例模式
  • 原文地址:https://www.cnblogs.com/moomcake/p/9385895.html
Copyright © 2020-2023  润新知