• L2-011 玩转二叉树


    L2-011 玩转二叉树 (25 分)

    给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

    输入格式:

    输入第一行给出一个正整数N≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

    输出格式:

    在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

    输入样例:

    7
    1 2 3 4 5 6 7
    4 1 3 2 6 5 7
    

    输出样例:

    4 6 1 7 5 3 2

    本题跟L2-006 树的遍历思路一致
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <stack>
    #include <queue>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int N = 1100;
    int a[N], b[N];	// a 中序遍历序列, b 前序遍历序列 
    int tree[N], sum[N];	// tree 暂时存放树中的结点, sum 层序遍历序列 
    
    void build(int n, int la, int ra, int lb, int rb)
    {
    	if(ra < la || rb < lb)
    		return ;
    	if(ra == la)
    	{
    		tree[n] = a[la];
    		return ;
    	}
    	
    	for(int i = la; i <= ra; ++ i)  // 记得是遍历数组a, 一定注意!!!
    	{
    		if(a[i] == b[lb])
    		{
    			tree[n] = b[lb];
    			build(2 * n, la, i - 1, lb + 1, lb + i - la);
    			build(2 * n + 1, i + 1, ra, lb + i - la + 1 , rb);
    		}
    	}
    	
    	return ;
    }
    
    void bfs(int s)
    {
    	queue<int> q;
    	int cnt = 1;
    	q.push(s);
    	while(q.size() != 0)
    	{
    		int p = q.front();
    		q.pop();
    		if(tree[p] != 0)
    		{
    			sum[cnt++] = tree[p];
    			q.push(2 * p + 1);
    			q.push(2 * p);	
    		}
    	}
    	
    	return ;
    }
    
    int main()
    {
    	int n;
    	memset(tree, 0, sizeof(tree));  // 记得初始化
    	cin >> n;
    	for(int i = 1; i <= n; ++ i)
    		cin >> a[i];
    	for(int i = 1; i <= n; ++ i)
    		cin >> b[i];
    	
    	build(1, 1, n, 1, n);
    	bfs(1);
    	
    	for(int i = 1; i <= n; ++ i)
    	{
    		if(i == n)
    			cout << sum[i];
    		else
    			cout << sum[i] << " ";
    	}
    	
    	return 0;
    } 
    

      

  • 相关阅读:
    AspNet Core 核心 通过依赖注入(注入服务)
    AspNetCore 中使用 InentityServer4(2)
    AspNetCore中使用Ocelot之 IdentityServer4(1)
    AspNetCore+Swagger 生成Model 描述
    scp带密码拷贝文件
    redis集群之节点少于六个错误-解决
    [AWS DA Guru] Serverless compute Exam Tips
    [AWS] Lambda Invocation types
    [AWS Developer Guru] CI/CD
    [AWS] Lab: CloudFormation nested stack
  • 原文地址:https://www.cnblogs.com/mjn1/p/10567290.html
Copyright © 2020-2023  润新知