• 1006. Sign In and Sign Out (25)


    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    

    Sample Output:

    /*
     * water.. 找最小时间  最大时间对应的学生账号 换算成秒就可以了。
    */
    #include "iostream"
    using namespace std;
    struct Node {
        string id;
        int cTime;
        int lTime;
    };
    int main() {
        int n;
        cin >> n;
        Node *p = new Node[n];
        for (int i = 0; i < n; i++) {
            char id[15];
            char cTime[8], lTime[8];
            cin >> id >> cTime >> lTime;
            p[i].id = id;
            p[i].cTime = ((cTime[0] - '0') * 10 + cTime[1] - '0') * 3600 + ((cTime[3] - '0') * 10 + cTime[4] - '0') * 60 + (cTime[6] - '0') * 10 + cTime[7] - '0';
            p[i].lTime = ((lTime[0] - '0') * 10 + lTime[1] - '0') * 3600 + ((lTime[3] - '0') * 10 + lTime[4] - '0') * 60 + (lTime[6] - '0') * 10 + lTime[7] - '0';
        }
        int MIN = 24*3600;
        string MINX;
        int MAX = -1;
        string MAXX;
        for (int i = 0; i < n; i++) {
            if (p[i].cTime < MIN) {
                MIN = p[i].cTime;
                MINX = p[i].id;
            }
            if (p[i].lTime > MAX) {
                MAX = p[i].lTime;
                MAXX = p[i].id;
            }
        }
        delete[]p;
        cout << MINX.c_str() << " " << MAXX.c_str() << endl;
        
        return 0;
    }
    SC3021234 CS301133

  • 相关阅读:
    AIX root用户密码丢失怎么办?
    Oracle 11g Grid Infrastructure 卸载
    Failed to create a peer profile for Oracle Cluster GPnP. gpnptool rc=32512
    管理 IBM AIX 中的用户
    vbox克隆文件的路径如何修改?默认它生成在C盘,怎么修改?
    Oracle_dataguard__11G_配置与维护手册
    AIX管理员常用命令
    如何让你的SQL运行得更快
    ORA00604: 递归 SQL 级别 1 出现错误,ORA01000: 超出打开游标的最大数
    Adobe Acrobat 9.0“ PDFMaker无法找到Adobe PDF Printer 的打印驱动程序”解决办法
  • 原文地址:https://www.cnblogs.com/minesweeper/p/6282250.html
Copyright © 2020-2023  润新知