• PAT 1076. Forwards on Weibo (30)


    Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

    M[i] user_list[i]

    where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

    Then finally a positive K is given, followed by K UserID's for query.

    Output Specification:

    For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

    Sample Input:

    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6
    

    Sample Output:

    4
    5
    
    /*  题目大意是: 一个微博用户发帖 根据关注他的人数 求最大可能被转载的次数 而且最多只能被间接转载m-1次
        注意:和六度空间基本相同  但这里是单向图 
    */
    #include "iostream"
    #include "queue"
    using namespace std;
    int Count;
    bool map[1001][1001] = {false};
    int n, m;
    void bfs(int x) {
        Count = 0;
        bool visited[1001] = {false};
        queue<int>q;
        q.push(x);
        visited[x] = true;
        int last = x;
        int tail;
        int level = 0;
        while (!q.empty()) {
            x = q.front();
            q.pop();
            for (int i = 1; i <= n; i++) {
                if (map[x][i] == 1 && !visited[i]) {
                    Count++;
                    visited[i] = 1;
                    tail = i;
                    q.push(i);
                }
            }
            if (last == x) {
                level++;
                last = tail;
            }
            if (level == m)
                break;
        }
    }
    int main() {
        cin >> n >> m;
        for (int i = 1; i <= n; i++) {
            int l;
            cin >> l;
            while (l--) {
                int x;
                cin >> x;
                map[x][i] = 1;
            }
        }
        int k;
        cin >> k;
        while (k--) {
            int x;
            cin >> x;
            bfs(x);
            cout << Count << endl;
        }
        return 0;
    }
  • 相关阅读:
    【特种兵系列】String中的==和equals()
    windows7 x64下maven安装和配置
    微信开发之本地接口调试(非80端口,无需上传服务器服务器访问)
    Java微信公众平台接口封装源码分享
    jdk安装
    用户权限管理
    Linux常用命令(一)
    Xshell显示中文乱码问题
    伪装虽易测试不易之微信浏览器
    每次新建项目出现appcompat_v7 解决方法
  • 原文地址:https://www.cnblogs.com/minesweeper/p/5937669.html
Copyright © 2020-2023  润新知