• Pku1218


    <span style="background-color: rgb(204, 204, 204);">/*
    A - THE DRUNK JAILER
    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
    Submit
    
    Status
    
    Practice
    
    POJ 1218
    Description
    A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
    One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the
    hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He
    repeats this for n rounds, takes a final drink, and passes out.
    Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.
    Given the number of cells, determine how many prisoners escape jail.
    Input
    The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.
    Output
    For each line, you must print out <span style="color:#6633ff;">the</span> number of prisoners that escape when the prison has n cells.
    Sample Input
    2
    5
    100
    Sample Output
    2
    10
    By Grant Yuan
    2014.7.11
    */
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    bool a[101];
    int main()
    {int m,n,i,j,sum=0;
        cin>>n;
        while(n--){memset(a,0,101);
              cin>>m;
              for(i=1;i<=m;i++)
                for(j=1;j<=m;j++)
                 if(j%i==0) a[j]=1-a[j];
              for(j=1;j<=m;j++)
                 if(a[j]) sum++;
                  cout<<sum<<endl;
                  sum=0;
        }
                  return 0;
    
    
    }
    </span>

  • 相关阅读:
    手把手玩转win8开发系列课程(5)
    一道百度之星编程大赛题的随笔联想·(2)
    手把手玩转win8开发系列课程(7)
    手把手玩转win8开发系列课程(10)
    一道百度之星编程大赛题的随笔联想·(1)
    手把手玩转win8开发系列课程(6)
    手把手玩转win8开发系列课程(9)
    手把手玩转win8开发系列课程(3)
    Innodb 表修复
    NoSQL之【Redis】学习(二):配置说明
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/4304011.html
Copyright © 2020-2023  润新知