• 杭电ACM-The Snail


    Problem Description

    A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day. 

    Day Initial Height Distance Climbed Height After Climbing Height After Sliding 
    1 0 3 3 2 
    2 2 2.7 4.7 3.7 
    3 3.7 2.4 6.1 - 

    Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.

    Input

    The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.

    Output

    For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

    Sample Input

    6 3 1 10
    10 2 1 50
    50 5 3 14
    50 6 4 1
    50 6 3 1
    1 1 1 1
    0 0 0 0
    

    Sample Output

    success on day 3
    failure on day 4
    failure on day 7
    failure on day 68
    success on day 20
    failure on day 2

    给四个数字
    H-总高
    U-初始速度
    D-下滑距离
    F-速度下降的概率
    先计算出每次速度下降的大小为U*F
    然后统计出天数,当天起点高度,爬升距离,爬升后的高度,下滑后的高度
    然后下滑后的高度小于0就失败
    爬升后的高度大于总高度就成功


    源码:

    #include <iostream>
    #include <cstdio>
    using namespace std;
    int main()
    {
        double H,U,D,F,sum,down;
        int day,flag;
        while(cin>>H>>U>>D>>F&&H!=0)
        {
            if(H==0 && U==0 && D==0 && F==0)
            	break;
        	sum=0;
        	day=0;
        	flag=1;
        	down = (U*F)/100;
        	while(sum <= H)
            {
                if(sum < 0)
                {
                    flag = 0;
                    break;
                }
                day++;
                sum += U;
                if(sum > H)
                	break;
            	sum -= D;
            	U -= down;
            }
            if(flag)
            	cout<<"success on day "<<day<<endl;
        	else
        		cout<<"failure on day "<<day<<endl;
        }
        return 0;
    }
    

    运行结果:



    @ Mayuko


  • 相关阅读:
    三个心态做人做学问 沧海
    成功走职场要找准自己的"快捷键" 沧海
    免费离线下载 拂晓风起
    Hibernate 获取某个表全部记录时 奇怪现象 (重复出现某个记录) 拂晓风起
    无法读取mdb 如果连接不了ACCESS mdb文件,就尝试安装MDAC 拂晓风起
    Netbeans 使用 Hibernate 逆向工程 生成hbm和pojo 拂晓风起
    如何点击单选框 radio 后面的文字,选中单选框 拂晓风起
    Java 连接access 使用access文件 不用配置 拂晓风起
    mysql下如何执行sql脚本 拂晓风起
    Hibernate配置access Hibernate 连接 access 拂晓风起
  • 原文地址:https://www.cnblogs.com/mayuko/p/4567562.html
Copyright © 2020-2023  润新知