• ZOJ Problem Set–1879 Jolly Jumpers


    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

    1 4 2 3

    is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

    Input
    Each line of input contains an integer n < 3000 followed by n integers representing the sequence.

    Output

    For each line of input, generate a line of output saying "Jolly" or "Not jolly".

    Sample Input
    4 1 4 2 3
    5 1 4 2 -1 6

    Sample Output
    Jolly
    Not jolly


    Source: University of Waterloo Local Contest 2000.09.30

    #include<iostream>
    
    #include<set>
    
    using namespace std;
    
    int main(void)
    
    {
    
      int n;
    
      while(cin>>n)
    
      {
    
        set<int> s;
    
        for(int i = 1;i < n; i++)
    
          s.insert(i);
    
        int preInteger = 0;
    
        int number;
    
        for(int j = 0; j < n; j++)
    
        {
    
          cin>>number;
    
          if(j != 0)
    
          {
    
            int integerInSet = (number - preInteger > 0 ? number - preInteger:preInteger - number);
    
            if(s.find(integerInSet) != s.end())
    
            {
    
              s.erase(integerInSet);
    
            }
    
          }
    
          preInteger = number;
    
        }
    
        if(s.size() == 0)
    
        {
    
          cout<<"Jolly";
    
        }
    
        else
    
        {
    
          cout<<"Not jolly";
    
        }
    
        cout<<endl;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    8051单片机指令和寻址方式
    C/C++的关系
    go JSON 读写到文件
    Oracle 对未提交事务的查询
    win8 iis 安装
    Silverlight 项目 对话框
    VisualSVN错误 Cannot query proxy blanket解决办法
    silverlight浏览器自适应问题
    windows server2003 多用户登陆问题解决办法
    silverlight 缺少对象错误
  • 原文地址:https://www.cnblogs.com/malloc/p/2490276.html
Copyright © 2020-2023  润新知